ConnectPort X3-R "Device Not Supported" by Digi ESP for Python. WHY NOT ??

ConnectPort X3-R “Device Not Supported” by Digi ESP for Python. WHY NOT ??
Digi ESP for Python reports that my ConnectPort X3-R (CPX3-R XATA) “Device Not Supported”. Can Digi ESP for Python be somehow updated to recognize it? The problem is reported by the Device Manager > Digi Device Discovery, when it fails to Create a New Configuration for the device. The USB(COM3) connection does work,and I tried to Register Device Manually, but that also failed. What next? Thanks.

It looks like the newer ESP don’t support it. I seem to remember it will work with ESP 1.4.0. Have you tried that?

I seem to remember hearing Digi was trying to move away from the X3 and use the X2e in it’s place.

Hello kjensen8,

thanks for getting back to me, and my apologies for not getting back sooner; temporary re-direction of priorities. I’m glad to see that you are a “Seasoned Professional”.
I have since found out, as you have indicated, that I needed to get an earlier version of DigiESP For Python, which does support the X3-R. However, it seems that I have gotten myself even more mixed up. I’ve been trying to follow the Getting Started Guide, and I get slightly, but not insignificantly, different displays, and now I can’t seem to connect to the device at all.
I should say that our company has these X3-R devices, so that’s what I have to work with. Also, I initially was able to get it recognized via the Etherios Device Cloud 2 weeks ago, but not today. I have also previously been able to get the Dashboard to connect to it, but also not today.
At this stage, I am wondering what is “square 1” that I can start with. Windows Control Panel - Device Manager? It seems to show up under Modem as Wavecom Wireless cpu #2, and it reports “device is working properly”. Under Diagnostics, Query Modem reports that the “port could not be opened”. The Digi X3 Dashboard reports that it is “Unable to detect the ConnectPort X3”. So I am perplexed as to which starting point can I definitely go to, like reset the device? Device Cloud? When I started up Digi ESP for Python, and proceeded with the Device Manager, and then the Device Discovery, I got stuck at the point of Run As > Remote iDigi Python Application, as it reported “Reboot Timeout”. Any further suggestions? What is a reliable "square 1 o start at? Thanks very much, AWK


I too apologize for not getting back to you.

I’d recommend not using the X3. I have the impression that it’s going to be obsoleted soon. The X2e is a good replacement.

If I may jump in, I am getting the same “device not supported” using the x2e you mention. its the wifi zb one. I use 1.4.0 (the only version available for mac… ugh). Luckily 2.2 on a PC seems to be moving along ok for the x2e.