Could not find any device - Error reading hardware version


I have used the XCTU app and dev board successfully several times to run AT commands and microPython scripts but since yesterday I got this error message when I try to connect the device :

“Could not find any device in port usbserial-XXX > Error initializing XBee device parameters > Error reading the hardware version”

I have tried the recovery option without success.

I got the same error with 1 Xbee and 1 Xbee3 devices.

Any idea ?



What interface board are you using? Are you powering it externally?

What happens if use the XBee recovery function?

What happens if you try to enter the bootloader manually via the DTR line being held low and triggering a reset with the Break enabled?

Digi Support

Thank you.

  1. XBIB-U-DEV and yes it’s powered externally
  2. The recovery function completes but I got the same error after I try to connect again (I also tried the recovery mode with the cellular modem flashing option )
  3. I’m not sure how do that, do you have any documentation that shows the procedure?

Ok, instead of using the “Add device” option, if I use the “Discover device(s)”, it’s working.

Check each of your statements!


That is because the baud rate that the radio is actually configured for is different than the rate you told XCTU to look for the radio at. That is why the Auto search function worked.

Digi Support

I have the same problem! how can I overcome this?

“Could not find any devic in port COM4 > Error initializing XBee device parameters > Error reading hardware version”

I have two Xbee 3 pro. One works without problems, the other gives this error