Cygwin Installation Problem

I installed Cygwin, On my Windows 2000 machine and the Cygwin installation ended giving me no errors. However when I tried to Install X-tools from the second CD, it complained about “Cygwin not installed”. Please Advise…

We’ve found a potential installation issue with the Microcross GNU installation in NET+Works for Gnu. When installing Cygwin, it is possible on Windows 2000 machines for the Cygwin install to finish without correctly creating all the registry entries needed for the subsequent XTools install routine to detect Cygwin. This has only been observed on Windows 2000 machines, but potentially affects both NET+Works v5.0 and 5.1. An investigation has been started with Microcross to determine root cause and ultimately to eliminate the problem. In the near term, we are making no changes to NET+Works installation scripts or documentation. The install program itself properly advises how to correct the problem locally. See below for full details.

I had a similar problem. I was, however, to overcome the problem by install Cygwin onto my C:\ driver instead of D:, where I had previously tried to install it. This has led me to believe that Microcross is only looking in the C:\ drive for the Cygwin directory.