Dead ConnectME _with_ JTAG

My Dev Board ConnectME (with JTAG) died suddenly. It just sits and flashes the green light. I didn’t put any new program or anything in it, it just stopped working. Anyone seen this before?


P.S. I can send a new program through the JTAG, but it still doesn’t work.

Thanks Cameron for your reply.

For all reading this, it appears that the green light flashes a diagnostic when there is a major failure and the flashes can be counted to determine the problem.

Mine had an error that needed an RA with Digi, but several of my other modules had a “9-1-1” error which means that the flash was unprogrammed. (It turned out that there was a ground fault.)

Same problem here, just opened our second dev-kit. The device worked for couple of days and now it is totally dead - it just stopped working. I can run naftpapp in debugger and flash image with it, but after reboot the device stays quiet - Can’t even access the rom console.

So can I return this to somewhere? It was bought last september and we just started using it. The Raven PSU was dead in this devkit package and next day the ME stopped working - so the whole kit was dud ? :slight_smile:

Please contact Digi Support at or (953) 912-3456, so that we can confirm the current state of this ME module. If we can confirm that the module is, indeed, non-recoverable, an RMA can be generated to provide you with a working unit.

If you are a customer in Europe, please contact your local distributor to obtain a replacement module.