Debug linux app on Wi-MX53 board: target selection failed

Hi all!

I tried to debug my linux application on my Wi.MX53 board.
'Launching … ’ has encountered a problem
Target selection failed Connection refused

ftp is working, cause the executable file was transfered to the board correctly

someone an idea?


What is your linux machine’s IP?
Is this in a VM?

If you are able to ftp to module from linux machine then it should be fine.

Verify your settings for device in Device Manager of Digi ESP


I have the same problem with a Development board and ME9210 (ME 9210 Linux Dev Brd).

When creating target, I do not worry. It communicates well.

It worked more than 10 times. But now I have the same message:

‘Soft Launching’ has Encountered a problem.
Target selection failed.

Target selection failed. Connection refused. Connection refused. Connection refused.

It’s not with VM.

Digi ESP give us a joke that lead this problem!
The FTP need a authentication! you must be care of it.

I also encountered this problem.