Digi Embedded Linux 5.7: Target selection failed

I am using DEL5.7 in VM. When I debug the Hello World application as ‘Remote C/C++ Application’, I get the following error:
Target selection failed. Connection refused. Connection refused. Connection refused.

I have checked the FTP connection and the settings look fine. Also, the binary is downloaded in /tmp.

When I run the application as ‘Remote C/C++ Application’, the binary is downloaded to /tmp, however, it doesn’t execute in Remote Console. If I login to the ME9210 module, I am able to run it in /tmp.

Any help is greatly appreciated.

Are you able to telnet the board? Is gdb daemon running on target? Are you trying this with stock images on the module?

Yes, I am able to telnet into the board. No, gdb daemon is not running. How do I run it? No, I have loaded new image.

I have enabled ‘debug tools(strace, Itrace, gdb)’ under ‘pre build applications’ in the image.

Also, I don’t understand why in run configuration the binary is transferred to target but doesn’t run in the ‘Remote Console’.