dgrp_cfg_node init not creating serial ports

Per the installation instructions, I’ve been using the command:

dgrp_cfg_node init AS 25

every time that I restart my computer. My EtherLite32 has worked so far, but now it doesn’t create the serial ports, and doesn’t produce any output.
Is there anything I can do to try to debug this?

You will want to look over your /var/log/messages file for errors.

Is it possible your system is configured for automatic updates and the kernel was updated?

If so, the driver will need to be removed and reinstalled for the new kernel.

I got this working, although I don’t remember how, and it worked until I rebooted my computer. Running dgrp_cfg_node init gives the error messages:

insmod: can’t read ‘/lib/modules/2.6.31-19-generic/misc/dgrp.o’: No such file or directory
ERROR: couldn’t load driver (err: 0).

There is no dgrp.o file in the directory shown, but there does exist /lib/modules/2.6.31-17-generic/misc/dgrp.ko.

I think I did update my kernel; before running into my initial error, I installed the package “kernel-package” in Ubuntu’s Synaptic Package Manager.

I have now attempted to reinstall the driver by just going to the dgrp_[version]-[arch].deb file, and running the command “sudo dpkg -i [file]”, and this is the output:

(Reading database … 167389 files and directories currently installed.)
Preparing to replace dgrp 1.9-24 (using dgrp_1.9-24_i386.deb) …
Running Pre UnInstall script…
RealPort (dgrp) startup scripts must be manually removed – see release notes
Unpacking replacement dgrp …
Setting up dgrp (1.9-24) …
Running Post Install script…
RealPort (dgrp) startup scripts must be manually installed – see release notes
Converting config file…
Checking to see if UDEV appears to be used on this system…
Yes, moving Digi RealPort UDEV rules to correct location

Processing triggers for ureadahead …
Processing triggers for man-db …

Is this not the right command for uninstalling and reinstalling the driver?

Thank you very much for your help.

Whenever a new kernel is installed, the driver must be removed and reinstalled to build against the new kernel (i.e.: dpkg -r dgrp; dpkg --purge dgrp).