Digi ESP Python encountered a problem launching project - Error retrieving remote device's firmware

An error showed up on my My Digi ESP Python when I tried to launch my project to remote Digi Python application, as below.

<<‘Launching hello_digi_world’ has encountered a problem. Error retrieving remote device’s firmware: >>

Now, I realised that the question had been asked before in: http://www.digi.com/support/forum/9135/error-retrieving-remote-devices-firmware, but it was left hanging. I have checked the Remote File Explorer and when I tried to refresh the file list, I got another error:

<< Error “2” while performing “do_command” action: Name not registered. (file_system) >>

I can access the gateway through the cloud and also from my browser via the gateway configuration interface using its IP address though…

What Digi device are you using?

I’m using the XBee Gateway - Wifi

When installing Digi ESP for Python, did you specifically check the option to install components for the XBee Gateway/ConnectPort X2e Family? Also, did you install the newer Python versions?

I uninstalled the program and reinstalled it, this time with ConnectPortX2e Family and I still see the same problems (I thought mine was a ConnectPortX4 though…) For Python I thought I read somewhere that asked me to choose version 2.4, but I have problems retrieving the files remotely so I’m not sure it has to do with the Python version…

The Xbee Gateways require Python 2.7, did you install this? Is the gateway configured successfully within the Device Options > Device Manager?

Hi, I went back and looked for another Digi ESP installer for the XBee Gateway, realising that mine did not have Python 2.7. The files can be retrieved now, yayy!! I must have downloaded the wrong application for Digi ESP for XBee gateway. My gateway firmware indicates that it uses Python v2.4 though, that’s why I was confused. Thanks for the leads! There are some other problems but with some luck I hope I can get through them soon!