Digi WR21 OpenVPN client on a Mikrotik OpenVPN Server

Has anyone successfully configured a Digi WR to connect to a Mikrotik OpenVPN Server?

I was given the files :
auth (containing username / password)

On the same OVPN server I am connecting 4 clients (Raspberry Pi) each connected on the LAN side of the Digi WR and it works.

I followed the steps from the “AN_47_Digi_TransPort_OpenVPN_client” but I am unable to get it connect. Event log contains :

12:31:53, 22 Oct 2019,OVPN 0 down
12:31:53, 22 Oct 2019,GP socket connected: -> ovpn_server_ip:443
12:31:53, 22 Oct 2019,TCP Req: -> ovpn_server_ip:443

AFAIK, Mikrotik OpenVPN does not support :

connection without username/password



Hi and welcome to Digi Forums.

as far as I remember, we had customers using OpenVPN between TransPort routers and Mikrotik devices, but we don’t have specific details on the configuration and version they use, so I can just suggest you to check the following, basing on the details provided:

  • Protocol and port: on the TransPort router are by default set as UDP and port 1194,so if the server is listening on a different protocol/port, the connection will not work.
  • Topology: please note that the topology type “subnet” is not supported om SarOS, but only topology net30, and the same needs to be used on the Server to have the tunnel working.
  • Compression: I am not sure if it is used on the server side, but please note that is not supported on SarOS, so you may want to disable it in case is enabled on the server.

For any further help, please review our support options on our website: https://www.digi.com/support.
Please note that Open VPN troubleshooting usually requires an Expert Support level. If your company already has it, please email to tech.support@digi.com and we will deeper troubleshoot the issue.


Digi Technical Support Team