Driver problem: VMWare ESX, Windows 2008 Std x64

I am not able to connect the AnywhereUSB/5 to a Windows 2008 Standard x64 server running on VMWare ESX.
I have installed the latest driver downloaded from When trying to connect, a found new hardware wizard is displayed but Windows is not able to find the correct driver for AnyshereUSB Remote Hub.

I have several boxes working on Windows 2003 x86 hosted on VMWare ESX.

Torge Hjorth

Found New Hardware error.

vcredist_x64 has been installed on the server.


Please upload the file c:\windows\setupapi.log.

I think the file has a differnt location and name on Windoes 2008. I have uploaded C:\Windows\INF\SETUPAPI.DEV and SETUPAPI.APP.


Please find the logs attached.



Your AnywhereUSB is defective. Technically, it was serialized incorrectly - part of a bad batch of units.

Would you like to get a RMA through us, or would you prefer to go through your distributor for a replacement?

We will return it to our supplier. A new batch has been ordered.

Looks like the issue is still not solved. Replaced the hardware today. The new box acts the same way as the old box. I does not connect to the Windows 2008 server.

Can you upload the setupapi.log file?

This is the log generated when attaching the new hardware. I am interested in this line:

! dvi: Error 0xe0000228: There are no compatible drivers for this device.

>>> [Device Install (Hardware initiated) - AWUSB\AWUSBRHUB_0201\Concentrator_10.200.1.108]
>>> Section start 2009/10/07 11:05:22.784
ump: Creating Install Process: DrvInst.exe 11:05:22.855
ndv: Retrieving device info…
ndv: Setting device parameters…
ndv: Building driver list…
dvi: {Build Driver List} 11:05:22.996
dvi: Searching for hardware ID(s):
dvi: awusb\awusbrhub_0201
dvi: Enumerating INFs from path list ‘C:\Windows\INF’
inf: Searched 0 potential matches in published INF directory
inf: Searched 32 INFs in directory: ‘C:\Windows\INF’
dvi: {Build Driver List - exit(0x00000000)} 11:05:23.650
ndv: Selecting best match…
dvi: No class installer for ‘AnywhereUSB Remote Hub (’
dvi: No CoInstallers found
dvi: Default installer: Enter 11:05:23.653
dvi: {Select Best Driver}
! dvi: Selecting driver failed(0xe0000228)
dvi: {Select Best Driver - exit(0xe0000228)}
! dvi: Default installer: failed!
! dvi: Error 0xe0000228: There are no compatible drivers for this device.
dvi: {DIF_SELECTBESTCOMPATDRV - exit(0xe0000228)} 11:05:23.673
ndv: {Core Device Install}
ndv: Device install status=0xe0000203
ndv: Performing device install final cleanup…
! ndv: Queueing up error report since device installation failed…
ndv: {Core Device Install - exit(0xe0000203)}
ump: Server install process exited with code 0xe0000203 11:05:23.701
<<< Section end 2009/10/07 11:05:23.719
<<< [Exit status: FAILURE(0xe0000203)]

Message was edited by: torge

I have no problems connecting the hardware to a Windows 2003 x86 server. The problem is only on the Windows 2008 x64 server. The hardware seems to work. It look like a driver problem on Windows 2008.

Are you sure you’re using the right AnywhereUSB driver? Only the latest driver (v2.70) supports Server 2008, and you would need to use the 64-bit variant. Here’s a link:

Yes. Thats the driver I got.

This is how it looks like in the device manager when trying to connect to the device.

The PID of 0201 tells me that this unit has that problem where it was serialized incorrectly.

You can work around this by manually adding new hardware (vendor Digi / product AnywhereUSB). Most likely that’s how the other Windows PC got it installed.

I am still not able to get it to work on Windows 2008.

When cheking the working installation (2003) I have found these drivers loaded.

1st: Network Attached USB Enumerator
2nd: USB Peripheral Server Host Controller.
3rd: USB Peripheral Server Root Hub.

The last driver is installed when the second is up and running. I am not able to get the second driver running on 2008.

Is there a way to identify the units that serializes incorrectly? Serial number?

The best thing to do is get the unit repaired from Digi.

I will send you an e-mail shortly with the RMA form.