Edgeport/1 and Ubuntu

There’s any guide and driver to install my Edgeport/1 device to Ubuntu 8.04?
I have no clue how to do it…

What kernel version are you running? To determine this, run the command “uname -a”. If it’s a 2.4 kernel you’ll have to download and install the Edgeport driver package for Linux. Otherwise, if it’s a 2.6 kernel, just plug in the Edgeport since the driver is built into 2.6 kernels.

I’m running 2.6 kernel

Linux 2.6.24-19-generic #1 SMP Wed Aug 20 17:53:40 UTC 2008 x86_64 GNU/Linux

I plug in the Edgeport, but I don’t know where it’s supposed to appear a COM port.

Anyhow just for checking, I’ve connected a device (HP48) to the edgeport and tried to connect (using HP Talx) and the app is unable to connect.

Should I activate the Edgeport somehow?

Linux doesn’t use COM ports. It uses device nodes. An Edgeport/1 should be accessible as “/dev/ttyUSB0”, so you’d want to tell your app to use that particular device node. To check that the device node exists, issue the following command:

ls -al /dev/tty*

tty0 should be listed after running that command. Are you seeing it?

When I type:
ls -al /dev/tty*

That’s what I get:
(attached text file)

tty0 appears at the top, but I don’t see the ttyUSB0 device node…
The edgeport is connected and I even have restarted the computer just to make sure that I’m in a clean environment.

Anyhow, I list usb devices and the following line should belong to the edgeport.

Bus 001 Device 003: ID 1608:0240 Inside Out Networks [hex]

Oops, I meant to say ls -al /dev/ttyUSB0

You don’t need to issue that command now, though. Just saying.

Hmm, I don’t see “USB” in your file (as in /dev/ttyUSB0). As a “sanity check”, solely for troubleshooting purposes, can you try to install this Edgeport/1 on a Windows XP PC? This will give me confidence, or not, that the Edgeport hardware is in working order.

Here’s a link to the latest driver:

Simply run that file, which extracts the contents to “c: emp” then plug in the Edgeport and point the found new hardware wizard to “c: emp”. You may get multiple wizards - if so, follow the same procedure. After the Edgeport is installed, it should be listed in the default General tab of the Edgeport Configuration Utility, which you can assess via the start menu shortcut. Double-click the Edgeport and it should say “Port 1 - COM (some number)”. Is that what you’re seeing, or do you have trouble installing the Edgeport on the Win XP PC as well?

The edgeport works perfectly under Windows.
Here’s a screenshot I’ve taken. You can see COM1 is assigned and I’ve stablished a connection with the sample serial device (HP48).

Thanks for doing that. That gives me confidence that the Edgeport is in working order, hardware-wise.

If you haven’t already, I recommend asking the Ubuntu community about this. Here’s a link to free tech support options:


In the meantime, I’ll try to get help from the engineering group who maintains the Edgeport driver.

No answers at Ubuntu Forums… Any news from your side?

Are you running the Desktop Edition or the Server Edition?

Can you give me more details of the computer hardware?

Hi, I’m having issues too, but with the Edgeport/416. What does your system show after you plug in the Edgeport/1 and type:

$ dmesg

I’m having troubles because of the many different chipsets the Edgeports have used in the past. Some show up under /dev and work, some show up and don’t work, and some don’t show up.

Hope this information helps:

I’m running Desktop Version. Gnome 2.22.3 Kernel 2.6.24-19-generic

Some hardware details:
AMD Athlon™ 64 X2 Dual Core Processor 5200+
2 x 1GB DDR2 667MHz

Motherboard: ASUS M2A-VM
___*PCI0: ATI Radeon X1200 Series
___*RTL8111/8168B PCI Express Gigabit Ethernet controller

Hard disks:
___* MAXTOR STM332082
___* Maxtor 6V320F0
___* Seagate ST3160021A


USB port where Edgeport is connected (info got from lshw command)
___description: USB Controller
___product: SB600 USB (OHCI0)
___vendor: ATI Technologies Inc
___physical id: 13
___bus info: pci@0000:00:13.0
___version: 00
___width: 32 bits
___clock: 66MHz
___capabilities: ohci bus_master
___configuration: driver=ohci_hcd latency=64 module=ohci_hcd

___product: OHCI Host Controller
___vendor: Linux 2.6.24-19-generic ohci_hcd
___physical id: 1
___bus info: usb@1
___logical name: usb1
___version: 2.06
___capabilities: usb-1.10
___configuration: maxpower=0mA slots=2 speed=12.0MB/s

___description: Generic USB device
___product: Edgeport/1
___vendor: Digi International
___physical id: 1
___bus info: usb@1:1
___version: 0.01
___serial: I73555228-0
___capabilities: usb-1.10
___configuration: maxpower=80mA speed=12.0MB/s

I’m sleuthing this way:

In /etc/modprobe.d/options, if you edit the file and add the line:

options io_ti debug=1

then unplug the Edgeport, remove the kernel module with:

$ modprobe -r io_ti

Clear the dmesg ring buffer with:

$ dmesg -c

and plug the Edgeport back in, wait a bit, and capture all the debug info with:

$ dmesg > debug.io_ti

I’m finding that when I plug the Edgeport into a Windows machine, the firmware Windows puts on is 5.30. When I then plug it into my server box, the current Edgeport firmware image in io_fw_down3.h is 4.80, and something breaks during the download. Also, why it wants to revert firmware backwards, and across a major version is beyond me. I’m beginning to think of hacking the device driver to make it ignore the FW revs.



What is the 50xxxxxx part number (and revision) of your Edgeport/416?

What Linux distro are you running, and what’s the kernel version?

Here’s the dmesg output and the debug.io_ti output once cleared the dmesg ring buffer.

I’m using a few 50000780-01s, which are okay, and a lot of 50001359-01s, some that work and some that don’t. I am running Ubuntu 2.6.24-21-server.

I’ve attached the output of dmesg when the edgeport was switched from Windows (to get it green blinking again) to the Linux machine.

I told Mike Swift I was heading over here to the forums, in case he asks :slight_smile:


You all may want to update Ubuntu to 8.10 to see if that resolves the issue.

I had a customer recently report trouble using an Edgeport/4 (newer model with the TI chipset) on an Ubuntu 8.04 system. The trouble he was running into was that his Edgeport/4 wasn’t even being enumerated. No color/activity on the system status LED and device nodes not being created. He updated to 8.10 and that seems to have fixed it. I’m not sure if that’s related to your scenario or not but wanted to share that info with you just in case.

Thanks, Jeremy! Ubuntu 8.10 fixed my problem with the Edgeport/416.

Yeah! I upgraded to Ubuntu 8.10 and now the edgeport works like a charm…
Thanks for your help!

Thanks for the updates. I’m glad to hear that fixed it. Another customer found the following info in the changelog for Ubuntu 8.10. Perhaps it’s related.

commit 1769c339cde4c1da819ee97513e9340413cef3c5
Author: Alan Stern
Date: Thu Oct 23 17:35:07 2008 +0000

USB: don't rebind drivers after failed resume or reset

commit 6c6409459a18a825ce12ecb003d5686af61f7a2f upstream

This patch (as1152) may help prevent some problems associated with the
new policy of unbinding drivers that don't support suspend/resume or
pre_reset/post_reset.  If for any reason the resume or reset fails, and
the device is logically disconnected, there's no point in trying to
rebind the driver.  So the patch checks for success before carrying
out the unbind/rebind.

There was a report from one user that this fixed a problem he was
experiencing, but the details never became fully clear.  In any case,
adding these tests can't hurt.