Edgeport/21 + Windows XP 2.0

I have the latest drivers (3.6) and when the install runs I get “An error occured during the installation of the device. The parameter was incorrect.”

Unistall doesn’t work, although if I launch edgeport.exe and use the uninstall from there, it seems to remove it OK. The red light keeps blinking and it does not work.

The unit has worked before. I also have an edgeport/4 but haven’t tried it yet.

Any suggestions?

I tried it with the edgeport/4 and same result. So it doesn’t seem to be related to the hardware (on the edgeport side at least).


Follow this procedure and let me know your results.

Download the v3.60 Edgeport driver package here:
Save the file to your desktop and double-click it afterwards. Extract the contents to “c: emp360” instead of “c: emp”.

Download the latest Edgeport Configuration Utility here:
Save the file to your desktop and double-click it afterwards. Click on the Advanced tab, then click the Uninstall button. Reboot the PC afterwards.

When Windows loads, a found new hardware wizard should appear (if not, make sure an Edgeport is attached).

Choose “No, not this time” if prompted to search Windows Update for the driver. Choose “Install from a list or specific location (Advanced)” at the next window. Select the “Search for the best driver in these locations” radio button. Uncheck “Search removable media” and place a checkmark by “Include this location in the search”. In the location field, type “c: emp360” (without quotes) and click Next. Choose “Continue Anyway” if prompted. You may get multiple wizards - if so, just repeat this procedure until no more wizards are presented.

After going through all the wizards, you should get a bubble stating the hardware is installed and ready for use. Verify you are now running v3.60 by opening the Edgeport Configuration Utility (click start, click Run, type “edgeport”, then click OK) and examining “edgeser.sys” under the Version tab. It should read 3.60.8.

If you’d like, you can safely delete the edgeport.exe and ip4n5360.exe files from your desktop now.

Every few months I try this again with no success on any of my 3 edgeport devices.

The setupapi.log shows that the Class installer is causing the issue. It seems to be selecting ImpsCoIn instead of EdgeCoIn (I think) although that may be correct. Any ideas?

Thanks. This was pretty much what I did. I tried both versions, and I had already discovered the uninstall on the app.

However, I did it again anyway. No luck. Same problem.

  1. Double-click My Computer, then click “Tools / Folder Options”, click the “View” tab, scroll down and uncheck “Hide extensions for known file types” then click OK. (Leave it unchecked if it’s already unchecked.)

  2. Double-click your Local Disk ( C: ) then double-click your Windows folder, scroll down and delete “setupapi.log”.

  3. Unplug all Edgeports from the PC.

  4. Follow the same instructions I just posted above and try to install only the Edgeport/21.

  5. Let me know exactly at what point during the installation you get that error message.

  6. After the installation fails, e-mail your newly-created c:\windows\setupapi.log file to jeremym (at) digi.com.

One of many log files.


What you should do is use the latest uninstaller that we have which should clean up the registry more efficiently to take care of the different coinstaller issue you’re seeing (we changed hardware class between sets of our drivers which causes problems if the user tries to “update” the drivers)

Grab these drivers here and then extract out the edgeport.exe program from the edgeport.cab file and run it. Go go the advanced tab and click on uninstall/reboot when prompted. Once back up plug in the Edgeport and point it to the location of the new drivers.


Let me know how that goes.

Hi Mike,

Nope. Same problem I always have. Same error message “parameter incorrect”. I’ve tried this a variety of ways and even tried to remove everything from the registry manually, so I was skeptical but I did download the 4.40 in the link below and follow the instructions.

Any other thoughts?


I’ve seen this before, no matter what we try to do the drivers will just not install. It seems to be something related to the registry but we never did figure it out exactly.

If you could go ahead and unplug the Edgeport and do another uninstall using the latest installer and then get me an export of your HKEY LOCAL MACHINE branch (running regedit) I can take a look.

Please just zip it up and email it to me directly at mikes@digi.com