Edgeport/4 - can't use 2 ports

Help please. I have an Edgeport/4 that is connected to a USB Hubport/4 connected to a Dell Precision M90 running Windows XP Pro SP3. Edeport driver is v4.50.

When I installed the Edgeport, I ran the confidence test from the configuration utility (nothing plugged in to the ports) and all ports passed. The green status light is flashing slowly. Edgeport configured itself as follows: Port1 - COM3, Port2 - COM4, Port3 - COM10, Port4 - COM11.

I can access ports 1 and 3 (COM3 and COM4) successfully, but I get error messages from all of my software about being unable to open ports 3 and 4 (COM10 and COM11). Attached is a Word file with screen shots of the Edgeport Properties windows and the Device Manager window showing ports.


Expand the “Bluetooth Radios” and “Modems” categories in Device Manager then go to the properties of each of the devices inside of those categories. What are the COM port numbers for each of them? For the modem(s), click on the “Modem” tab to see the COM port number. I’m not sure about the Bluetooth device(s) - you may have to dig around if it’s not obvious.

Both the Bluetooth Radios and Modem were disabled before Edgeport drivers were installed. Originally Modem was using COM3 and Bluetooth was using ports COM9 and COM10

Are they still disabled? I think that when devices are disabled, their relative sections in Device Manager are automatically expanded, so I’m not sure that they are still disabled.

Yes, they are still disabled. They were expanded, but I manually closed them down before I took the screen shot to make the image smaller and fit on one page.

As I said before, the Modem was using COM3 and the Bluetooth was using COM9 and COM 10. With both the Modem and Bluetooth currently disabled, I can use COM3 and COM9 successfully with Edgeport, but not COM10 or higher. My application software won’t allow selection of com ports over COM12.

— Kerry

I’ve seen certain older software applications have problems opening “double digit” COM port numbers before. Maybe that’s the problem you’re running into. To see if that’s the case, change the two problematic Edgeport COM port numbers to single digit numbers (via the Edgeport Configuration Utility, not Device Manager) then reboot the PC to make sure that change is saved. Of course, be sure to use COM port numbers that aren’t being used by other devices.

I did test this the other day and single digits all seemed to work OK. COM10 and higher all failed to open.

I also tested the Edgeport by swapping the lower ports numbers (1 & 2) with the higher ports (3 & 4) to make sure it wasn’t an Edgeport hardware problem. It didn’t make any difference which Edgeport port had the double digit COM port number - it still didn’t work. All single digits worked on all ports.

I tried the double digit ports with two different software applications with the same failure result. It makes me think it is an operating system issue.

Or perhaps both of those software applications have the “double digit” problem.

Doesn’t sound like an Edgeport issue.

For troubleshooting purposes you could try using that Edgeport on another PC (preferably one with a clean/minimal install) with the same two apps, so see if the problem follows those apps or not.

Do you know of a serial port utility or some other piece of software that I could use to rule out an OS problem?

Try HyperTerminal.