replaced Edgeport8 - can't use 8 port numbers

I have an Edgport 8 which i replaced with a different Edgeport 8. At the time I didn’t know about the method of making the com port numbers “stick” to the usb regardless of the device. Consequently, ports 3-10 show “already assigned to another device such as another COM port or modem.”

I have a number of pieces of hardware that only support up to port #8, so this is a real drag. I no longer have the original edgeport8. Is there any way to “free up” those numbers? I looked in the SerialDevices area of LocalMachine/hardware registry Key, but there were no entries for ports 3-8.



From my experience, that error message is not accurate so I would just ignore it.

I tried ignoring it, the device I’m using gave me this error message:

“error opening com8 - Port is busy (in use by another application)”

I’m assuming the application is the edgeport app. I’ll dig around and look for sys config files or something that maybe i can clean up.

any ideas?

Run the digital loopback test according to the instructions in this KB article and let me know which ports pass/fail.

I hope you don’t mind but I did a modified test, mainly because my setup is gargantuous (but also because I’m remoting in from work and not actually in front of the system at the moment). I have TONS of software that boots automatically, using 12 COM port devices. Disabling all of that when things work relatively well is just going looking for trouble. :slight_smile:

What I did was assign the port#8 from my edgeport8 to comm port 8 (It previously worked on com 22). There is no hardware listed in the edge port or device manager that says it is com port 8. It is one of the ones that I get the afore mentioned error with.

I selected that and the port7 on the same edgeport for the test. port7 is currently configured as comm 21, and i know for a fact that there is some software using it right now.

I ran the digital loop back test with those two and got the following results:

Port 7 = Passed
Port 8 = OPEN

I don’t know if that will help or not.

OK let’s forget about the digital loopback test then. It’s only reliable if run in that fashion (all serial cables disconnected from the Edgeport, etc.).

So, the issue-at-hand is that some software is giving an error related to not being able to open COM 8 (Edgeport serial port 8), right?

Tell me, how did you change the Edgeport COM port numbers? Through the Edgeport Configuration Utility or through Device Manager? If you used our util then note that you sometimes have to unplug/replug the Edgeport or even reboot the PC after making that change, for the new COM numbers to “stick” so that could be the source of the problem.

Also tell me more about your serial devices and related software. For example, what serial devices are attached to each of the Edgeport serial ports? How many software applications are you running that are related to those serial devices? Which applications are related to which devices? And so forth…

The issue is that if I cahnge edgport serial port 8 (or any of them, for that matter) to any com port # between 3 and 10, the software is not able to open it. it is not just a specific software that can’t open it, but any of them.

I’ve tried changing the port# with device manager and the utility. I get the same response with both, that another application is using that port #.

I’ve tried several combinations of rebooting, disconnecting, etc. I suspect it is something that the old edgeport 8 is not “letting go of.” I think it’s more than coincidental that there are 8 port numbers i can’t use.

“I’ve tried changing the port# with device manager and the utility.”

That could be the source of the problem. You should use the Edgeport Configuration Utility exclusively. Using Device Manager instead could cause problems.

My suggestion would be to uninstall the Edgeport using the uninstall button (under the Advanced tab) in the Edgeport Configuration Utility then re-installing it after rebooting (it will prompt you to reboot).

That did it, thanks. I’ll be sure to only use the config utility to change com ports from now on (now to reconfig 12 port settings)