Edgeport 4 RS-232 USB Convertor - Win7 32-bit Prof - COM1 unable to open on startup

I think I have the latest driver -

The problem is when my computer starts up, the device manger shows everything is ok, my 4 ports are present and there are no warnings or errors that I can tell. However, when I attempt to open COM1 with my application or hyperterminal, the port cannot be opened.

If I then, select the port, disable it, and then enable it, the port works fine until I have to restart the computer, then I have to do it all again.

Any idea’s on why the driver does not work?

The Digi label shows:

PN: (1P) 50000787-01
SN: (S) I71622664

Product Configuration Re-order number: 301-100-04


Yes, 5.30 is the current release Edgeport driver.

For troubleshooting purposes, try this:

  1. Run the Edgeport Configuration Utility.
  2. Click the Configure button and change the COM port assignments to 101, 102, 103, 104.
  3. Click OK once then unplug the USB cable from the Edgeport and plug it back in.
  4. Click Refresh, double-click the Edgeport (to expand it) and confirm that the COM port numbers have changed to 101 - 104.
  5. Click OK again to close the EP config util.
  6. Reboot the computer.
  7. Create a new connection in HyperTerminal to COM 101. Does it error or not?

Note that you will still see the old COM port assignments (the “friendly names, technically” in Windows Device Manager. This is a cosmetic bug that we’re aware of, which will be fixed in the next EP driver release. Be assured that the COM port numbers DO change and the accurate numbers are listed in the EP config util.

Ok I did that and the COM101 worked on startup. Then I used that configuration utility to switch it back to COM 1-4, and followed the same procedure. Then rebooted.

COM1 still fails. I ran the Confidence Test from your configuration utility and it says COM2-4 Passed, but COM1 shows “FAILED [Could Not Initialize Port]”

I wouldn’t have an issue with this except our existing software uses COM1 for communication to our controller. So COM1 must work every time the comptuer reboots.

This doesn’t look like an “Edgeport problem”. It sounds like you’re running into a COM port conflict regarding COM 1. Disable COM 1 in the BIOS if applicable, dig around Device Manager to see if you have any other devices using COM 1 (if so, disable them or rename their COM port number) etc.

This problem happens on 2 completely different types of computers, one a DELL T3500 and the other a laptop that has no comports except those supplied by the USB Edgeport. I have tried it using the Edgeport 22c and the Edgeport/4 - happens on both of them. The only common thing in all those tests is the driver, well that and me. I could be setting things up in the wrong order, I just don’t know what to do. I am following the same procedure we use here at work when using WinXP, and we never had this problem before.

I have looked over the device manager and no other devices are using COM1, and no conflicts show up. I also used “Process Explorer” and followed the tips on other forums to search for COM1 (or any “serial” device). Nothing comes up, so I am pretty sure COM1 is not in use. Also, when I assigned the first port to COM1, it did not show COM1 as in use, which usually happens if like lets say my mouse or modem was defaulted to it.

As I said, after the reboot, to get the port working all I have to do is select it, disable it, and then re-enable it and it works fine after that until the next reboot.

That additional info is good to know.

I tried to re-create this issue on a Win 7 32-bit system, with the same EP driver, but couldn’t. I have no problems opening COM 1 (of the EP) immediately after booting up. Since Win 7 doesn’t come with HyperTerminal, I’m using the executable that I grabbed from another computer.

Have you tried PuTTY? It’s a good free terminal program. You may have better luck with it. Granted, it sounds like you were just using HT for troubleshooting, so even if PuTTY works, your app still won’t work. But it would be another data point (if PuTTY turns out to work) so it’s probably worth trying.

If you haven’t already, you may want to uninstall/re-install the EP. To uninstall, click the Uninstall button under the Advanced tab of the EP config util and reboot the PC when prompted.