Edgeport/1i port assignment issue

I installed the drivers for my 1i but when I went to use it, I could not connect to a known good device. As best I could determine, the auto-assigned COM 3 is in conflict with my laptop’s modem. In the docs, it suggests that the unit will assign to a port based on s/n. In this case my unit is s/n (S)W80649111. I adjusted the app settings as to choose a port. Port tests would pass (tried 4,5,6,8) but still no connect to my device.

Another oddity of the app is that it would not allow choice of the protocol, seems locked to RS-232 when I bought and required its RS-485 functionality. My company has used these before and I will not say our lot is PC literate, so am wondering what I am missing? In desperation (since I was in Japan and at a customer site), I did install a competitor’s unit and it worked straight away assigning to COM 5. As I mentioned, my company has used these before and we intend to proliferate them with our start up systems… need help sorting this. Thanks!

Based on your serial number, that is indeed an Edgeport/1i which can do RS-422 or RS-485.

  1. Am I correctly understanding that you changed your Edgeport from COM 3 to other COM numbers (4,5,6,8)? If so, how did you do that? For example, through Device Manager or through the Edgeport Configuration Utility?

  2. Am I correctly understanding that the known good device RS-485?

  3. >> “Another oddity of the app is that it would not allow choice of the protocol, seems locked to RS-232 when I bought and required its RS-485 functionality.”

What app?

Hi, sorry… should have been more explicit. Question #1 and #3, I was working with the Edgeport Configuration Utility.

For question #2, it is a known good RS485 device.

Normally, we use your Edgeport connected to a DB9 to RJ-45 adapter and then into the liquid flow meter. In the case of the competitor’s unit I got to work, it was an RS-232, through a RS-232 to RS-485 adapter, then the DB9 to RJ-45 adapter, then to device

Hopes this helps to clarify.


Thanks for the clarification of the “s” designator being the one software selectable. This was not clear in the docs I had looked at previous.

As to cabling, our cabling/adapter series is configured correctly. I was using a known good cable/adapter to a known good device. Another Edgeport 1i had been used previously… also, I had our lab unit working with my laptop before. My current issue seems correlated to the laptop or the the unit. I plugged this current one in and expected it to work. I had old drivers and reasoned this may be the issue. I loaded the new drivers and no change. Then I loaded them fresh onto my colleague’s laptop, same result. Both me and my colleague’s Lenovo X60s both were configured the same upon load of the drivers… assigning to COM 3, then using the utility, tried different ports… no change.

When I got the chance on my next trip to Calif, I can try to use the one in our lab there to determine whether it is the unit itself.

Yes in both accounts. The cabling / special made DB9 => RJ-45 was the same as used before. Also, the serial device (both of them in the system) have been connected to before. The BIG variable seems to be my laptop to Edgeport 1i config? Since I was at a customer site in Japan and COULD NOT fail to get the communications going to run diagnostics, I installed a competitor’s USB to RS-232 unit along with a locally sourced RS-232 => RS-485 adapter… it started working straight away on COM 5. After I finished the required scope of work, I tried again to config the Edgeport to COM 5 but could not. AS I said before… I HAVE had an Edgeport 1i working on my laptop prior. My system see the unit, the port tests “good” but no com.

Let me be exact… “No com” means no communications… that this particular unit is not allowing data flow between the 485 device and my laptop. The software provided with this product is not indicating there is a problem. The only problem I am seeing is this unit wants to configure to COM 3 which is not viable on the laptop. When I choose another port… still no communications. When I go to Santa Clara next week, I will plug into another like kind unit and it will work perfectly… as it has for the last 2 years. This unit in my hand, for what ever reason, is not functioning like it should. Note… I need to verify what is going on here. The resolution of this impacts the sales of a couple of hundred of these units as the product proliferates. I was pleased with the SW support question I had asked and was solved… but this thread seems not to be going anywhere.

Yes, this helps.

Only the “s” kinds of Edgeport (for example, Edgeport/8s) supports the ability to change the signal mode via the Edgeport Configuration Utility. The “s” stands for “software selectable”.

The Edgeport/1i is different. For your Edgeport/1i, you need to do the cabling a certain way, for either RS-422 OR RS-485. See the Edgeport Industrial Installation Guide for details.


Follow the cabling diagram in the Edgeport/2i section, which is immediately below the Edgeport/1i section.

Are you saying that the cabling is the exact same cabling that you previously used, with a different Edgeport/1i?

If so, is the serial device the exact same one that was used with that other Edgeort/1i, and the same cabling?

OK, can you give me more details about “no com”? What are the exact symptoms that suggests it’s not working? For example, does the software you’re running to talk to the 485 device give any error messages? Or do you just not see any data that you expect to see? Or is the data corrupt? Something else?

OK, seems like a simple case of defective hardware - that particular Edgeport/1. Generally, I’m pretty confident in our hardware so you’ll have to excuse the time spent ruling out other possible causes of the issue. I’ll be glad to open a RMA request for you. I’ll e-mail you the form shortly.