Please Help Edgeport/4 connects to base USB Port but not Hub

I have been fighting with this for a couple of days and I hope someone here can help.

I have two different Edgeport/4’s which both display the same symptoms.

When I connect the Edgeport to the USB port on my computer, the device works (ie. I can open the ports via PuTTY and the Confidence test passes).

I need to connect the divice to a USB Hub, however. When I connect the device to any port on the hub, the drivers seem to install, the Configuration utility sees the device and the ports. However, when I run a confidence test, all ports report “OPEN” and something else. It looks like another 4 character word which is wrapping in the text field and only the top line of pixels for the second line appears.

If I try to open the ports with PuTTY, the connection fails with “Unable to open connection to COM11” followed by “Unable to open Serial Port”. This happens for all ports.

The versions of Software are:

edgser.sys 5.00.06
ionenum.sys 5.00.03
edgecoin.dll 5.00.03
impscoin.dll 5.00.03
edgeport.exe 5.56.2

and the OS is XP SP3 running on an xPlore C1 Tablet computer.


Attach one of your Edgeport/4’s to the USB Hub then run the confidence test using the instructions in this Knowledgebase Article (follow steps 1-7):

Do the ports Pass, Fail, or still report being OPEN?

The link didn’t work but I figured it out to be

I tried your suggestion with the same results. I have attached a file showing some of the system settings.

The TQI USB device is a built in GPS that is part of the hardware as is the FTDI USB to Serial adapter. These two devices are configured as COM1 and COM3 respectively.

As I mentioned earlier, the system configuration and drivers remain the same when I plug the Edgeport into the machine directly without the USB hub and everything works.

Thanks for your help.

In your initial post you said that PuTTY gave the following error:

“Unable to open connection to COM11”

I don’t see a COM 11 on your PC. Was one of your Edgeport’s ports configured for COM 11 at that time? I presume so but need to know for sure.

What is the make and model of the USB hub you’re using? Have you tried other hubs? If so, how do they behave in comparison?

You are correct. One of the Edgeport’s is configured for COM 7 thru 10 and the other COM 11 thru 14. I have tried three different hubs (Ultra, Belkin F5U234, and Targus PAUH210) both powered and unpowered with the same results. They are all 4 port USB 2.0 hubs.

BTW, I also disabled the USB to Serial and TQI GPS’s and rebooted and tried again. Same results.


If you haven’t already, I’d like for you to try the previous v4.50 Edgeport driver and then let me know if the behavior changes or not.

You can get the v4.50 driver from our FTP site using the info below. The file name is “40002537.exe”. You should first uninstall the existing driver by clicking the Uninstall button under the Advanced tab in the Edgeport Configuration Utility then rebooting the PC when prompted.

If you are using a FTP client:
Host name:
Username: austin
Password: !15st3n!


If you are using Internet Explorer 6 (or a previous version), copy & paste the following address:


This will automatically log you in with the above Username & Password.


If you are using Internet Explorer 7:

  1. Copy & paste the following address:
  2. Click the “Tools” button at the top-right and make sure that “Menu Bar” is checked.
  3. click “View” at the top-left then click “Open FTP Site in Windows Explorer”.
  4. In the new window that opens, click “File / Login As”, enter the above Username & Password, then click the “Log On” button.

I think that I started with 4002537F.exe but I will try this version. I’ll let you know.

OK, I tried it with slightly different results. It was successful once but then I unplugged the USB and then plugged it back in and rebooted the machine. Then I got ‘FAILED’ for all of the ports.

…using the procedure in that KB article that I suggested earlier?

I was fairly certain that the answer was yes but to verify, I checked and reran the test. I have used the procedure and now get the error “FAILED” in the port test. The port numbers are COM 11 thru 14 with this device and do not conflict with any other devices.

In the Edgeport Configuration Utility, click the Configure button and change the Edgeport’s COM port assignments to 101, 102, 103, and 104. Click OK, close the Edgeport Configuration Utility then reboot the PC. Run the test again after Windows loads. Results?

All ports still failed

Swap that Edgeport with the other one, change the COM port configuration to 101, 102, 103, and 104 (like you did for the other one), then reboot the PC and run the digital loopback test again using the procedure in that KB article. Results?

The other Edgeport is installed in my truck at home. Will test tonight and let you know.


Same results!

Look under the Advanced tab in the Edgeport Configuration Utility for “MS High Speed Hub Fix”. Is it checked or unchecked? Whatever it is, choose the opposite. So, check it if it’s unchecked, or uncheck it if it’s checked. Click OK, reboot the PC and let me know if that helps or not.

First let me say that I really appreciate the time that you are spending!

I will try that tonight.

It still does not work. I have gone a different route by adding another USB Hub where the Edgeport was and installed two USB Serial adapters there. I needed to get things working. Hopefully I can get the Edgeport to work in the future.

We’d be glad to try to re-create this issue if you could sent us one of those hubs but I’m doubtful we would be able to re-create it. I think that the cause of the issue is related to that particular computer in some way, because we have not had reports of this issue before.

Would you be willing to purchase a Digi USB hub instead of one of your existing ones if the Edgeport worked with it? If so, we may be able to send you an evaluation unit to see how it behaves.

I think you may be correct because I the Edgeport works fine with a direct connection. What is the cost of a Digi USB Hub? If the cost is reasonable, I would be willing to try this option.

Thanks again for the help.