Help. Edgeport will not recognize any ports but One.

I have a basic Edgeport that has 8 port hook ups on it and i have tried everything but only 1 of the ports will ever be recognized by XP. I have sent it in to be looked at and it has been sent back saying nothing is wrong with it. i have downloaded the new drivers, windows says they are up to date and everything is o.k. however in the device manager only 1 port shows up and in the past all 8 of them used to show up but now only 1. I have also tried all 6 USB ports on my PC and its all the same thing.

Please help.

I’ll e-mail you shortly. Please reply to that with the following screen captures:

  1. Device Manager (maximized) with the “Ports (COM & LPT)” section expanded.
  2. Edgeport Configuration Utility, with the Edgeport expanded (so it lists the COM port assignments).

I have attached the file from Word, it wouldnt let me just paste the screen shot.


I’m not sure what you’ve done so far so I’ll let you continue with this one. I would suggest a complete uninstall/reboot/reinstall using the 4.50 edgeport.exe and drivers.

Interesting. I’ll e-mail you our latest (v4.50) Edgeport driver. Go ahead and try Mike’s suggestion. Click the Advanced tab in the Edgeport Configuration Utility then click the Uninstall button and reboot when prompted. After Windows loads, you should get a found new hardware wizard. Point the wizard to where the v4.50 driver was extracted (you can extract it wherever you’d like). Please let us know if this helps.

hey guys, sorry it took so long to get back on this, well i downloaded the drivers you sent me and it still doesnt work so i dont know what else would even help. i know the edgeport is fine like i said we had it shipped off twice because i just did not believe it was working right but it was confirmed twice that everything with it is fine.

What do Device Manager and the Edgeport Configuration Utility look like now, in comparison to before? If they’re different please upload a new screen capture for me like you did before.

Heres the new screen capture, i took two pics of it, the second screen capture has the driver tab open so you can see if those drivers are correct or not.

when i unplug the usb cord and plug it back in the edgeport, that little yellow tab pops up on the bottom that says ‘windows doesnt recognize the usb device’

For troubleshooting purposes, do you have another computer that you can install this Edgeport on? I’d like to know this Edgeport behaves on another PC in comparison.

Ok i hooked it up to another computer and it does the same thing, it says windows cant recognize the usb device. That was with the new drivers and everything

Thanks for taking the time to do that. Looks like bad hardware. I’ll e-mail you a RMA form.

Ok thanks i really appreciate it. I sent you an email back with everything for the RMA filled out.