Edgeport/4 "firmware: requesting edgeport/down3.bin"

Hi

When I plug in an Edgeport/4 I get the following error message:

[1212881.265053] usb 2-1.1: firmware: requesting edgeport/down3.bin
[1212881.960960] io_ti: probe of 2-1.1:1.0 failed with error -5

How can I resolve this?

I’m pursuing this because two of the ttyUSB lines occasionally “disappear” from my host server - Ubuntu 10.04 LTS - and I’m trying to rule out firmware.

A similar question was asked before in the context of a Edgeport/8 with seemingly dead ports and was answered by sans0909 however the answer is not visible?

Full dmesg on insertion

[1212875.920027] usb 2-1: new full speed USB device using uhci_hcd and address 5
[1212876.074098] usb 2-1: configuration #1 chosen from 1 choice
[1212876.077064] hub 2-1:1.0: USB hub found
[1212876.079352] hub 2-1:1.0: 1 port detected
[1212876.353932] usb 2-1.1: new full speed USB device using uhci_hcd and address 6
[1212876.466038] usb 2-1.1: configuration #1 chosen from 1 choice
[1212876.469036] io_ti 2-1.1:1.0: Edgeport TI 2 port adapter converter detected
[1212876.929846] usb 2-1.1: firmware: requesting edgeport/down3.bin
[1212877.663745] io_ti: probe of 2-1.1:1.0 failed with error -5
[1212877.896040] usb 2-1: USB disconnect, address 5
[1212877.896045] usb 2-1.1: USB disconnect, address 6
[1212880.256026] usb 2-1: new full speed USB device using uhci_hcd and address 7
[1212880.405315] usb 2-1: configuration #1 chosen from 1 choice
[1212880.408357] hub 2-1:1.0: USB hub found
[1212880.410537] hub 2-1:1.0: 2 ports detected
[1212880.689139] usb 2-1.1: new full speed USB device using uhci_hcd and address 8
[1212880.801254] usb 2-1.1: configuration #1 chosen from 1 choice
[1212880.804377] io_ti 2-1.1:1.0: Edgeport TI 2 port adapter converter detected
[1212881.265053] usb 2-1.1: firmware: requesting edgeport/down3.bin
[1212881.960960] io_ti: probe of 2-1.1:1.0 failed with error -5
[1212882.037923] usb 2-1.2: new full speed USB device using uhci_hcd and address 9
[1212882.289013] usb 2-1.2: configuration #1 chosen from 1 choice
[1212882.292995] io_ti 2-1.2:1.0: Edgeport TI 2 port adapter converter detected
[1212882.459021] usb 2-1.2: Edgeport TI 2 port adapter converter now attached to ttyUSB0
[1212882.459130] usb 2-1.2: Edgeport TI 2 port adapter converter now attached to ttyUSB1
[1212882.462872] usb 2-1.1: USB disconnect, address 8
[1212884.321558] usb 2-1.1: new full speed USB device using uhci_hcd and address 10
[1212884.574653] usb 2-1.1: configuration #1 chosen from 1 choice
[1212884.578623] io_ti 2-1.1:1.0: Edgeport TI 2 port adapter converter detected
[1212884.744656] usb 2-1.1: Edgeport TI 2 port adapter converter now attached to ttyUSB2
[1212884.744770] usb 2-1.1: Edgeport TI 2 port adapter converter now attached to ttyUSB3

Thanks in advance
Shrek