Error when installing RealPort on XP

Trying to install Realport on XP to connect to a EtherLite 80 with fw 1.6

Using software version 40002549_A.

When running Setup from command line, I get this error message:
C:\realport>Setup /install /ip= /firstport=COM11 /numports=8
Removing old INFs 100% [====================================>]
Installing new INFs 100% [====================================>]
Installing device 56% [====================> ]
Please contact Digi technical support with the following:
Error: 3758096900 | File: DgRpUI32\RpDevice.cpp | Line: 3094
Failed to complete operation!!

On Installing device section, it hangs on 18% for several seconds.

When using the graphical interface with the same parametres is almost equal.

We installed RealPort on several XP machines some years ago that are still working. Then we used software version 40002164_T. I have tested this one too on new machine, but it has the same error.

Vidar LJ

I do not recognize the error, so I sent your message to engineering and I’m awaiting a reply.
Are there any EtherLites installed in the device manager (or any partially installed devices)?

If yes, please try uninstalling them and then reboot the system. Please try to install the drivers again.

If it still fails, a customer (a former Microsoft support person) who was not able to install the drivers, did an “in place upgrade” also called a repair installation.
After doing this he was able to install the drivers. He was not able to determine if it was file or registry corruption, or a problem with some PNP function, or some other issue.

Thanks for the advice.
I ran Setup /upgrade first.
Then when running Setup /install /ip= /firstport=COM11 /numports=8, the driver installed itself beautilfully.


Vidar LJ