Etherlites gone after system restore

I am running AIX 5.2. This weekend I experienced a corruption of rootvg that required a restore from tape. After the restore my EL-8 & El-16 were no longer defined. When I try to redefine them I get the following error,
Method error (/etc/methods/cfgsts):
0514-038 Error loading kernel extension.
stsdd: errno 8
Anyone have an idea?

Sound like the EtherLite devices were not included in the backup.

You will probably need to remove and re-install the driver and re-add the devices.

Unfortunately I have uninstalled and reinstalled the drives and then attempted to reinstall the Etherlites. I received the same error.

I’ve got an etherlite 160 that I have updated with the latest firmware. I downloaded and installed the latest drivers for AIX 5.2.
I defined the etherlite 160 via smit and it looks OK. I defined a couple of ttys on the etherlite. No response on the attached terminal. I can get the the etherlite mini os on port 0 so my cabling appears to be ok.
My AIX system can ping the etherlite and the etherlite can ping my host.
Any thoughts?

Read the article you linked. When I try rlogin from my AIX host I receive “unknown host” message. I did rlogin plus the etherlite’s ip address. I am able to ping the etherlite from the host.

Just added the el160 ip address and a name to my hosts file under AIX and rlogin now works.

Just tried the stty -a < /dev/tty28 command. tty28 is what I’ve defined on the el160. After hitting enter, the curser drops a line and nothing else happens. No output, no prompt. I have to ctl-c out.

If I’m reading the documentation correctly loop back test is not valid for Etherlites. I can not telnet to the etherlite.

the sockets command only comes back with 2 entries. The third one you discuss is missing.

EL-160 RealPort Server - US Patent No. 6,047,319
? ver
Product: EL-160
FW Ver: V1.6
Ethernet: 00:A0:E7:23:31:F8


And I know the IP’s match.

A tough one for sure. I think I am going to uninstall the drivers, reboot the host system and start over. Any files I should check are gone after uninstalling?

result of telnet attempt;

telnet el160 771

Connected to el160.
Escape character is ‘^]’.

Connection closed. port

I have deleted all the tty definitions and removed from database, deleted the etherlite definition and removed from database, and uninstalled the driver.

digiasync.realport.obj ROOT DEINSTALL SUCCESS
digiasync.realport.obj USR DEINSTALL SUCCESS

Not sure I will be able to reboot tonight but will put this on hold till I reboot.
Thanks for your assistance to far!

Removed drivers. Rebooted last night. Reinstalled latest drivers. Defined el160. defined a tty and it WORKS!
Can my old EL16’s be used with then latest drivers?
And thanks for your help.

michaelt you are correct. Just updated the firmware on the EL16, defined on AIX added a tty and another success. Thanks once again for all you assistance!

Unfortunately, it appears you are using the obsolete “FAS” driver, so I do not know if I can be of much help.

You may want to see if you can view any existing EtherLite devices in the ODM:

lsdev -Cc (name)

For the RealPort driver, the “name” is “nts”. Not sure with the “FAS” driver.

Try removing any existing devices if found:

rmdev -l (name) -R -d

Then remove any existing driver.

If you are successful in removing the driver, you should consider installing the “supported” RealPort driver.

Loopback test of the serial port itself would be the best course of action, since it seems driver/network layer are in place.

Sounds like you’re reading an article written for a Portserver, which does support telnet.

This article should cover the process every step of the way. Loopback is the final operational test, and can be found in the last paragraph:

Since stty -a isn’t showing output, it means the serial port isn’t valid. So in this case, step back to the “rlogin” part and check the “sockets” output on the Etherlite. You should see a minimum of three entries there. One will be in a listening state, and should be listening on TCP port 771. Another will be TCP port 513 with the IP of wherever you’re rlogin session is from. The third will hopefully be TCP port 771, with an IP of the AIX host where Realport is running. If the last entry is missing, the driver isn’t talking to the hardware, and that’s the problem right there. Your “hosts” entry may change this behavior, if the driver was having the same problem as the rlogin attempt was.

So the driver isn’t connecting with the Etherlite, and that’s why you don’t have valid serial ports.

This may be an indicator of incorrect firmware on the unit (“ver” command via rlogin") for use with the Realport driver, the TCP socket connection or port 771 maybe being firewalled at some point between AIX server and Etherlite, or the IP address used to create the SA in the Realport driver does not match the IP address on the actual Etherlite hardware. One of those would be my best guess.

That actually sounds like a good idea. So, the firmware is definitely Realport firmware and would work with the driver, and if the driver is configured for the correct IP (and that IP isn’t a duplicate in use by something else), the only thing left is that either the daemon died (try rebooting the AIX server) or the socket connect from the driver on TCP port 771 is being stopped by a firewall somewhere between AIX and Etherlite. One way you can test the firewall possibility is to do the following from AIX commandline:

telnet 771

Though the Etherlite doesn’t actually support telnet, it doesn’t matter. That would still connect, just that it would close as soon as you hit enter on your keyboard. What we’re actually looking for is whether you get a “connection refused” error when the telnet is attempted, which would be an indicator of firewall or duplicate IP address on the network, both possible causes of the issue you’re experiencing.

If you want to go the uninstall route after trying what I listed above, make sure all the tty/lp devices are in a “defined” state, rather than “available”, and once the devices are defined, put the SA itself in a defined state. At that point you’ll be able to uninstall the driver. If something is still active, you’ll get a method error when attempting to remove the driver.

Yes, as long as you load or ensure that Realport firmware is running on your EL-16. Here’s the link to the EL-16 firmware page, in case your EL-16 still has FAS (7.x) firmware on it:;osvid=0&amp;tp=2