Firmware update bricked XBee Series 1 pro (parallax USB adapter) (noob)

I updated the firmware on one of my Xbees. The update process failed near the end and I can no longer communicate with my modem. After a bit of research it seems this might be a common problem that solved by reflashing using the bootloader (as in this tutorial: but after trying this method I only receive “…” from the XBee any time I try to transmit anything.

I have found other tutorials that suggest I could try to reload the firmware blind, but I don’t know where to look to find my modem type to set this up.

Any help with either process would be greatly appreciated. Thanks

You should follow the recovery guide unless you have a programmable XBee.
First if you are using a USB adapter follow this:
then the recovery guide:

What is the product number off the back of your XBee? I can use that to know what firmware you should use. (XB24-ACI-001 for example.)

1 Like

thank you so much, those guides worked first time.
great work!

This tutorial worked well for me,

I had a wifi Xbee that was unresponsive.
I was only getting “…” in the terminal

Tried all the steps until I got to the last step (“Next, we perform the full recovery:” )

Set my wifi Module to XB2B-WF and then programming the firmware worked.

Optimizing the USB to serial settings would really work and it worked for my modules. If you are not changing this settings you may receive an error like “flash checksum error failed … write parameters failed” while updating the module firmware.