gdbtk doesnt save the target settings

Hi everybody how can i make sure that then i load the gdbtk from command line the settings are stored? Now i have to set the target settings every time again (e.g. the file to load “source c:\pfad\hardware.raven”)

Run a “make gdbinit” before starting the debugger. See examples or template app. Adrian

Hi,I have the same problem since I installed the Net+OS 6.0 GNU-F Update (November 2004). With the normal 6.0 Version it worked (had to set up the target just once and never had to change it). Is there a solution already? It’s quite annoying to hack in the garget settings time and time again. Also breakpoints and watches are lost between debugging sessions. I have found the gdbtk.ini file which should store these settings in my user directory but it seems gdbtk does not alter it.

i cant find any makefile in the netosdir or in the cygwin dir that has the target “gdbinit” wenn i run “make gdbinit” from the template app dir it says “make: *** No rule to make target `gdbinit’. Stop.” so where do i have to run the command from? thanks for your help Volker

I am talking about NetOS61 on NS9750. You probably are using a different platform with 6.0. On 6.1 the make gdbint commands creates a file .gdbinit which is use by gdb as a command file. The contemt of the file looks like this: ---------- Starts here---------- echo Setting up the environment for debugging gdb.
set complaints 1 set output-radix 16 set input-radix 16 set endian big dir . set prompt (majic-gdb) set remotetimeout 10 # This connects to a target via EPI’s MDI Server # listening for command on this PC’s tcp port 2345 target remote localhost:2345 # Display MDI/MAJIC status information monitor DV "
"; DI # # Use the “monitor L” command to download your image since it # is much faster than using the gdb load command. # # # Please modify the path below for the “Monitor L” command and # save this file in the same location in which the image.elf file # is stored: i.e. 32b directory. # #monitor DV "
" #monitor L c:/netsilicon_netos_source/netos/src/examples/naftpapp/32b/image.elf monitor L c:/netos61_gnu/src/examples/namib/32b/image.elf ----------Ends here------------- You may try to create a similar file in your 32b directory. You have to change the target command (maybe with the source command) or put your manually introduced commands into that file Adrian