gdbtk not saving session settings???? Help

We just got the upgrade to NetOS Version 6.0e from 6.0. In installed the upgrade and now whenever i load gdbtk, my settings are always reset to the defaults. before with the previous version i was able to set up in the gui the target settings and have it automatically run the "source gdbconnectme.raven " command and then load. but now the settings are not persistent when i reload it. Please help, this has been driving me mad and is quite annoying. Thanks,



I suspect that the problem is that your ‘home’ directory (as per Cygwin is concerned) does not exist).

To verify, try do the following:

  1. Start a bash shell.
  2. Type ‘echo $HOME’ (without the single quotes, of course). Take note of the response.
  3. Type ‘cd ~’.
  4. If step 3 fails, then you must create the directory.

Now gdbtk should be able to save its session settings.


Hi Cameron,

I’ve the same problem. In fact, my $HOME variable is set to a network computer directory !!! And I don’t know why !
How can I modify it and how it must be set ?

Thanks for your help


Hello Gilles,

Try the following:

  1. From the Control Panel double-click on the System icon.
  2. Click the Advanced tab.
  3. Click the Environment Variables button.
  4. Under the windows labled User variables for , click the New… button.
  5. For Variable Name: enter HOME.
  6. For Variable Value: enter a valid path for your new home, i.e. C:\cygwin\home\gilles.
  7. Close all XTools shells and relaunch.
  8. Type ‘echo $HOME’. The result should be /home/gilles.