Get Xbee SE module


For create a smart energy thermostat, through the document I found, it should have a XBee SE RF module. But I haven’t found it in the “Products”, where could I get it and does X-CTU could do the configuration?

Thank you!


1 Like

It appears you will need to convert your XBee modules to SE capable:

You can download the Smart Energy Conversion Kit here:

Follow the instructions in the Conversion Kit to update your XBee firmware to the Smart Energy variant.

1 Like

Thank you for your respond, so it means that if I have a smart plug, I can take out the module and convert it to smart energy module? Just for academic use.

I’m pretty sure you will void the warranty if the enclosure is opened.

Yes you would void both the warranty and UL certification if you open it. But you can use the OTA function to perform a remote firmware upgrade on the module inside of the smart plug thus making it a smart energy device.

Thank your for your reply, for now I have changed the fireware to SE, but how could add the device to SE gateway? what’s the installation code?

An Install code is a code that is derived from the MAC address and the Certificates provided by Certacom. If you are not familiar with the SE standard. I would strongly advise you do some reading about the standard before you go any farther down this path. The reason for that is that there are functions about Joining in a Smart Energy network and how data flows that you will need to understand before you can do anything.

Thank you for your advise, yes i have begin to read the standard. For now, my module has added to the gateway(without link key and install code), but the module shows inactive. what should I do to make it active, or get further application of the module?

You need to install the Certificates and then allow them to Join. Once that has occurred, the modules will not do anything till told to do something or provided data from your application.

Hi, the problem still hasn’t solved… I have installed the certificate and the gateway is allow join, the module always shows inactive…
I have no idea where is wrong.
Thank you so much, again.

Did you follow the reset of the procedures outlined in the above documentation and on the site for creating a Server based Application that issues specific commands to allow Joining to occur?

yes, I use X-CTU for configurations.
for coordinator: ID=0 SC=3FFF SD=7 NJ=254 NT=255 EO=8 NK=0 KY=1 SN=4 SP=50;
for the module end device: ID=0 SC=3FFF SD=7 NJ=FE EO=8 SN=4 SP=50;
when I use API to register the module to the coordinator, the response of status is 02 (Device joined to network), but after 2s, it shows 03 (Device disassociated)
thank you so much!!!

XCTU does not do the required Server based authentication that needs to be done for a Smart Energy product to associate.

I would suggest you start by reading
Then I would suggest using the In Premieres display at

Hi, me again…sorry for disturbe, but I got a new problem. I’m not sure what I had done that make the SE gateway is inactive also, and the page of Smart Energy Developer Tools–Debug–command cant refresh, it shows Request timeout. And in the Device Cloud, smart energy part it shows:
Status: Inactive
Node Type (Role): Unknown
Manufacturer ID: 0xFFFFFFFF
Gateway Device ID: 00409DFF-FF60CCDE

And the log file:
Oct 21 20:32:48: System: Start
Oct 21 20:33:10: Security audit: + none root:python
Oct 21 20:33:12: Python autostart 1: Script ‘’ starting.
Oct 22 13:40:21: chronyd: Successfully contacted an NTP server.
Oct 22 13:40:31: Python autostart 1: ERROR: script ‘’ exited unexpectedly (code:1)
Oct 22 13:40:31: Security audit: + none root:python
Oct 22 13:40:32: Python autostart 1: Script ‘’ starting.
Oct 22 13:40:39: Python autostart 1: ERROR: script ‘’ exited unexpectedly (code:1)
Oct 22 13:40:40: Security audit: + none root:python
Oct 22 13:40:40: Python autostart 1: NOTE: delaying 2 seconds before taking action, due to recent reboots/restarts.

I tried update firmware and SE_framwork, doesn’t work.

can you give me some advice? Thank you!

What firmware versions does it have for the EOS and XBee? What SE Framework version?

Firmware Version: cpx2e-se release gw- 07/22/2015 16:41:26 CDT
XBee Firmware version:0x5132
Hardware version:0x2241
SE Framework:build_branch : release/1.6.10
description : SE Framework with support for X2e/X4 gateways and SE 1.1a features.
SE_spec_version : 1.1 revision 17
version :
I download form here: