How can I reset Xbee pro S3B (factory default)

Hi, I bought two Xbee Pro XSC (S3B). The xbee does not react after I configured something in old version of X-CTU. I clicked as followed. Modem configuration tab - Modem tab - I selected another version - Read. After that, error message shows up and does not blink in my Arduino UNO Xbee module. I could not find this case on the web.

Usually, “Read” button cannot harm a module. You should have WRITE something on module that lead up to this issue.

One option for you to re-flash firmware on this module. However, first check if your Arduino board has flow control lines in it (like Digi XBIB boards). Absence of these lines may lead upto to failed firmware update.

Steps to re-flash firmware can be found here:

If your interface board don’t have these flow control lines, then you can first optimize USB settings on your system and then try above mentioned guide link (high success rate but can’t guarantee completely):

1 Like

The XSC S3B version of the XBee modules does not function natively in the Arduino Uno boards. You need to make sure that the CONFIG pin on the module is NOT connected. You also need to make sure that the DTR and RTS flow control lines are connected for XCTU to properly read and write firmware to the module.

1 Like

Thank you asgm and mvut. I solved the problem.

  1. I downloaded the latest version of XCTU.
  2. Tool tab - XBee recovery - Select my model, firmware and COM port - Recover.
  3. Problem solved.

Glad to hear that you solved the issue.