How do I get a different Xbee module working in a Digi X4?


Hey there,

I recently contacted Digi and they recommended that I change the module within my Gateway from Xbee S2B to S2C. I did so today and as a result the module no longer boots up when I power on the Gateway. The digi Tech support said that the Modules come stock as AT enabled not API and that i need to enable that before I put the module in. He also said I have to change the baud rate.

Now this would make sense to me if i was trying to establish a network with the modules. However all i want is to see it turn on in the gateway. I am wondering if anyone has any clarification as to what is happening. Is he talking about the gateway hardware to the module or module to network?


The gateway firmware inside X4 talks to module on serial UART line with baud rate of 115200 & in API mode. However, by default XBee modules are shipped with baud rate of 9600 with AT firmware. Therefore, requirement to change Baud rate and firmware to API mode does makes sense.

1 Like

Ah I see, Thank you. Is it possible to do so without a dev kit? From the gateway? or do i need to purchase an interface? If so, what is the most cost effective one?

Also If i change the BD setting on the S2B chip to 9600 will the gateway adjust as well? Or will it make communication to the S2B impossible until I revert back out side of the gateway? Because if that is the case then wouldnt I be able to change it to 9600? Switch the chips and then change to 115200?

I have changed the Baud Rate and enabled the API mode. With AO = 1. Still the gateway responds with

“Gateway is Disabled”

You will need an interface board for first time. Later you can change parameter from gateway’s web ui. Sparkfun boards are quite affordable. But they are very basic boards & if I would be at your place, I would opt for Digi’s XBIB-U boards. They will prove out to be more worthy in long run.

S2B module should be at baud rate of 115200 to communicate with rest of gateway’s hardware serially.

then problem seems to be somewhere else, better to consult Digi’s tech support