How do I read values using remote AT commands

How do I read analog ports Xbee S6 with frame type 0x07?
I want to read the voltage applied to pin 20 (D0) of Xbee. The ip on the network it is How would the frame?

You can send “IS” command using 0x07 frame type. But in address field you have give 64 bit MAC address (DH and DL) of destination and not its IP address.

Sorry friend…but i don’t understand. You say DH, what is this command? I can’t find in datasheet. My problem boil down in send a 0x07 frame type for wifi remote module and obtain a answer with a analog sample of D0 port.
I tried to send several different frames, but dont got answer. For example:

I try send:

7E 00 xx 07 01 xx xx xx xx xx xx xx xx 00 49 53 xx

what i should write in address destination? I’ve tried my ip(of my microcomputer), the ip of module and the parameter ‘SL’(Serial Number Low) of my modulo.

Thanks for help! I realy need…

I realized that I was not very clear in my earlier response. Are you trying to read pin 20 of same module?

0x07 frames are used to read/set values of remote module using local module.

If its local module, then you need to send 0x08 frame.

If you want to read pin 20 of module2 from module1 then set address field in 0x07 frame with address of module2. Address of module2 is its SH + SL parameters. It will look something like 000000409D5D7375.

1 Like

So, if i understand, the 0x07 frame is only for the case where i have two or more modules, where one is local, in other words, one (the local) talking with the microcomputer by RS232 and with other modules by Wifi?
So the problem is, I bought only one module.
I have only a module connected in my infrastructure network. And I need read the analog sample in pin 20 this module, directly by the microcomputer. That is possible? How?

By example in page 60 of datasheet is possible, but until now I could not.

I go try send the 0x08 frame by socket, and see if I get answer.

That is a work of scientific initiation of my college, so i’m totaly layman in the question.
Thanks for help, again…

Also make sure that “AP” parameter on module is set to non zero value, otherwise no API frame will be helpful.

Yes friend, the “AP” parameter is configured in “1 API-enable”.