How to change IP address on RCM2000

We just need to change the IP address of the unit. We can ping the address @ but need to change it to .101. What type of connection to the RJ45 port do we need to use?

If you can ping your current ipaddress then the RJ45 connection must be working. To change it, you will need to change your application, if your application is running a static address of .103 you can change that to .101,
if is DHCP you can go to DHCP server and add an entry on the routing table to give address .101 to your specific units macaddress.

1 Like

Thanks. The unit is sitting on my desk attached to my laptop, and I have been able to ping it from CMD with no problem. The next step is logging in, which we cannot figure out how to do. You mentioned changing my application - what do you mean, specifically? I am using Putty / MobaXterm to attempt serial, FTP, SSH, and any other type of connection with no luck. I tried HTTP from Chrome with no luck, either.

What software have you installed on the module? What is it supposed to do? Maybe nmap would report open ports? It’s possible that it isn’t hosting any servers and only acts as a client. If you have source code, you can use the Dynamic C IDE to modify the source code and run it in a debugger.

On the RCM2000, it might be running an HTTP server, but it probably won’t have telnet, SSH, or HTTPS. It might just have a simple sample program on it that blinks LEDs and tries to ping a fixed IP address.

Thanks, all. We just got this figured out. It was in the FTP connection scenario. MobaxTerm was being rejected for connection - no earthly idea why. Putty worked but we were not getting responses that we expected. We ended up using the “v” and “g” commands to get useful responses. We then used the “ip” command and “ctrl d” (NOT enter/cr) and it all worked great.