How to enable Mesh Routing?

Hello,

I have several Xbee Pro S2B’s which I have successfully connected over AT mode (a few routers going to one coordinator).

My question is: how do I enable mesh routing (Ad hoc on demand)? I have looked through the datasheet, I was expecting it to be one of the AT commands but I cannot find it.

Anyone know how this is done? Thanks in advance!

I believe you can’t enable/disable mesh-routing explicitly. It’s enabled by default.

Every router (and the one coordinator) should route messages.
E.g: If one of your routers can’t reach the coordinator directly, the message will be routed over your other routers, which can route the message to the coordinator.

The routing happens behind the scenes. All you need to do is add a radio somewhere between the two non communicative radios and Mesh is automatically engaged. To talk to specific radios from any other radio (adhoc) set the DH/DL of the radio you want to talk from to the SH/SL of the radio you want to talk to. The meshing system will figure out the route for you. Note using API implicitly uses the SH/SL that you intend to be your destination as your destination enabling adhoc routing for you by design without having to set Dh/DL in AT mode.

Thanks for the replies. I spoke to a tech support guy at digi and he pretty much said the same thing.

My confusion was due to using the ATDB command, but according to the datasheet,

The DB command only indicates the signal strength of the last hop. It does not provide an accurate quality measurement for a multihop link.

All seems to be working now.

Hello Miken, I have some problems to set my Xbee Pro S2B (5 Xbees) to Mesh Network, I still found the X-CTU configurations, Could you help me

Hai Checkfluid, I have some problem to set A mesh network, I used Xbee Pro S2B, but still do not found the X-CTU configuration… please help me

Probably, the S2 family AKA ZigBee requires one and only one Coordinator be created to head up the network, the rest must be Routers and possibly some sleeping end devices (no more than 10 per router.) I personally would manually set my pan ID on all my modules as I like to make sure they do what I want them to do, However you do not have to do that, the default zero (0) as the Pan ID will work in most cases. Fresh radios will join up with no further effort, previously joined radios may need a ATNR0 command issued to it to tell it to join the new network. Other than in general that is all I can assist you with. In order to help you you must provide as much of a description of what you have done and what you want to do as possible. A simple help me is not going to get much in the way of assistance.

Thought, rather than ask everyone the same question. I would ask this at the top as a separate question. Please include as much detail about what you have done and and what you expect to do as possible.

First of all I would like to thanks for your response…
I use 5 Xbee Pro S2B and I wanna make it to mesh network
This is my schema :

On that schema, I use ATMega8 on node B,C,D,E integrated with thermal sensors…
I want :
-When Node C or Node D turned off, Node E automatically search another route
-When both of Node C and D turned off, Node E automatically search path between E and B if the distance possible (still in range)

I’ve been sets B,C,D as routers ; A as coordinator, E as end device
all settings using X-CTU, A as Coordinator API, B and C sets as Router API, E set as END DEVICE API, Shown below :



There are many parameters, could you help me how I must sets all parameters ?
I’ve sets C,D,E broadcast but I still don’t know the right settings…
Node B set to send the data to the node A
The parameters are :
Networking : ID, SC, SD, ZS, NJ, JN,
Addressing : DH, DL, NI, NH, BH, AR, DD, NT, NO, CR
Serial Interfacing : BD, NB, SB, D7, D6, AP, AO
Sleep Modes : SM, SN, SO, SP, ST, PO
Please Help me to fix this problem, Your help is mean a lot to me, thankyou before

By definition your usage of the S2B modules means you have a mesh network. The secret is in the addressing. You do not need to worry about in the middle routers, just who are you talking to. (warning usage of broadcast in a ZigBee network can cause a “firestorm” of packets being sent all over the place and will bring the network “to its knees” for a while. If you address radio 1 to talk to radio 10 and they are so far apart that they can not see each other they will discover a route through 2,3,4,5,6,7,8,and 9 on their own. The only thing you need to worry about is the source and the destination. I strongly urge you to use unicast addressing. Normally I would leave my settings at default as this is what Digi engineers have determined gave the best over all performance. If you have redundancy in your layout, that is if there are more than one radio in the RF reception area of a node then if one radio dies the system will reroute through the redundant node to self heal, the radios do this on their own. All you need to do is address your message to the node you want to send it to, and make sure you have enough radios powered up and operating on the proper PAN ID / Channel to handle getting the data there.
End devices are only used if that node needs to sleep to save battery power, otherwise I would never use a sleeping end node. You construct your network out of a single coordinator (the root) and a branching network of routers (the limbs and branches of the tree). Any end nodes are simple leafs attached to one of the routers.