How to fix "getData: failed" error while updating Xbee3 firmware?

My Xbee3 is not being recognized by XCTU when I want to add it as a new radio module. One of the suggested solutions is to use the recovery tool to update the firmware of the device. When I try to update, it fails with the error in the title of this post. The point at which it occurs is inconsistent (anywhere from 1% to 48%) programming progress. Any suggestions on how to fix my device?

Have you tried formatting the file system first or making sure that Micro Python is turned off?

I’m pretty sure micropython is not active but is there a way to ensure? Also, could you elaborate on formatting the filesystem?

You can query the PS and AP commands.

The File system commands can be found at

I think I need to start further back. My xbee3 is not responding to any AT commands from the serial console, including “+++”. Thus far, my attempts to fix this have been unsuccessful especially since many of the available guides are for Windows and I am on a Mac.

I am confident that communication between the XBee and my computer is working though, since the device is able to start the firmware reprogramming and the Rx and Tx LEDs are flashing appropriately.

Am I stuck in a certain setting or mode that I can’t escape from? Is there a series of bytes or packets that I can send to maybe remedy this?

You can try doing an OTA firmware update via a 2nd radio connected to the PC. Hopefully that works for you.

I don’t think it will work because both my xbee modules are having this same issue.

Try it. If it does not work, then I would reload XCTU and if that does not work, contact Digi Support

Ok, thank you for your help and advice @mvut!

Ultimately, I was able to solve this issue my connecting to a Windows machine, but my Xbees still fail to connect on my Mac. Perhaps it has something to do with the USB drivers on Macs.

Either way, if anyone in the future ever has this issue, I would recommend the Windows release of XCTU, if accessible to you.