Unsupported firmware file binary format

Dear all,

I just bought a Xbee Pro S1 with an USB adapter. After taking over an hour to download your XCTU software for Windoes from your website (on my 100MBit connection ;-). I wanted to start the software, and first had to install another round of updates, even though the download has just finished some minutes ago.

Then I was able to finally start communicating with my XBee. I was able to connect to it and read all configuration. Then I wanted to update the firmware to 10ee. However the update process had an error (“Unsupported firmware file binary format”).

Since then I am not able to connect to my XBee anymore. Recovery efforts have the same error.
I am really annoyed with my experience with XBee and the process so far. So please either send me a quick tutorial on how to fix this error or just send me a new XBee with a USB adapter.

Sadly, your forum does not allow for attachments to be uploaded, else I would be able to send you a screenshot of the error message.


ps. I tried running the software for the Mac as well (after also downloading it for over an hour on my 100MBit connection); I was not able to start it, since it exited with an error.

Hi Daniel,

There’s a problem with the 10ee firmware. It is corrupt and XCTU cannot read it, so you have to recover your module and update its firmware to another different version (10ed, for example).

To do so, go to XBee recovery within the Tools button at the top. There, select the port where your module is connected to and the new firmware. In your case, it would be:

  • Product family: XB24
  • Function set: XBEE 802.15.4
  • Firmware version: 10ed
    Once done this, click the Recover button and your XBee module will work properly again.

Thank you and sorry for the inconvenience.