How to Upload Firmware plug and Play onto DC-ME-01T-C

I have a new DC-ME-01T-C module and now I want to Upload plug and play Digi Firmware onto it. I have Download the Firmware 82000856_F6.bin file from Digi site and I tried to Upload this Firmware onto module using Net+os programmer. I powered on the module and connected it to PC by Ethernet Cable.
Then I ran netosprog.exe using windows cmd and /Upload command and I Received Firmware uploaded successfully massage, but the module dose not work like DC-ME-01T-S. And I do not Know why. Would you please Help me on this problem.

I would suggest submitting a case to Digi Support regarding this by going to, logging in and submitting a case.

the -C modules are prepared to run NET+OS firmware only.
the -S modules are prepared to run Plug and Play (PnP) firmware only
Digi does not support to migrate it from one firmware to another. Trying to do so is voiding warranty and you might end up in a bricked device because the firmware is not booting anymore. NET+OS supports much more different flash chip variants. The plug and play firmware might find a flash chip which it doesn’t support!
Both devices use different boot loader for their EOS firmware, and it is a large project if you try to develop a NET+OS firmware which has the function set of the PnP firmware.

DC-ME-01T-S is obsolete and you need to switch to the DC-ME4-01T-S-UPW as replacement.

Trying to migrate/convert the DC-ME-01T-C into a DC-ME-01T-S due to unavailability of the DC-ME4-01T-S-UPW (supply chain shortage and one year lead time) does not solve the problem. In the end this shifts the supply chain shortage to customers who are in need of DC-ME-01T-C, so don’t try to migrate/convert … you brick the devices voiding warranty and you won’t solve any lead time problem with trying to do so.