How to upload new application to DIGI ME without loader

Hi I made a mistake and upload bad application to digi module (C-ME-01T-S). The problem is that this application doesn’t have enabled FTP server (with firmware upload capability). The application is OK and it is running in digi module, but i cant load new firmware. Is some way how to upload new firmware?

Thanks Jirka

I think you mean you have a DC-ME-01T-C (JTAG’less custom module)? -S modules only support Digi’s plug and play firmware.

If the ME is new enough, you can start the recovery process by shorting pins 18 and 20 to ground. When you do this you’ll see a recovery menu on the serial port @ 9600/8/n/1 no flow. When C’s start coming out of the serial port, use hyper terminal and do an Xmodem file transfer of the new image.bin. If it’s too old and the recovery isn’t built in to be enabled by shorting these pins, you have to figure out how to corrupt the application images flash (probably not possible unless you’re doing something bad in your code), or it’s now a paper weight.

If the module has a JTAG on it, you can use the ESP -> Help -> Recovering a Device process to recover the module.

It seems that there is bug in DIGI side.

In new update 7.3 in BSP update is BUG in TFTP recovery.

See this:
TFTP recovery failure

Case: none

Date Fixed: 04/18/08

Image download via TFTP completes, but does not execute.


Changed all members of the tftpc_conn_t structure to “volatile” as this structure is

accessed both from the bootloader code and the Ethernet interrupt processing code.


Thanks for the info - is there any way to tell whether a unit is new enough to support the serial XModem method?

Hi, yes i have -C module. When I short the 20 and 18 pins the digi module asks for new firmware via DHCP server (I have installed DHCP and TFTP server) As i can see in wireshark (ethernet sniffer) the DIGI module receives sucefully new image but it probably want load it in FLASH (RAM). The old application is still inside. There is also no communication on RS232.

Any ideas what to do?

If you’re certain that your updated application isn’t being saved to flash, then follow a simple two-stage process:

  1. Use DHCP/TFTP to download an application which will update flash from an FTP upload, such as the naftp example.

  2. When the previous code is running, use it to upload your new application and write it to flash.

You’re probably realising that its a good idea to include a simple method of updating flash into your code…

The problem is, that the failsafe asks and receives new images and thats all. The new application is not stored into flash and also is not running in digi. I tried to load fixed application with integrated FTP server, demo application and others but none of them is working.

I tried to load everything what I found. I’m sure that the digi receives the new image (image.bin) but it didn’t save in FLASH or it didn’t run it from RAM. The applications runs in DIGI ME with JTAG without any problems and they can be updated via FTP without any problems.

Does some one have image which works with failsafe?