ID block

Hi, I have used a modified version of the write ID block program to put a serial number in flash on RCM2300 modules - worked great a year ago.
But it doesn’t work today on the 2300 module, even if I set the board def correctly. Using the version 9.62 compiler (7.25 worked before, but not with current USB-RS232 cable :mad: ).

If I skip the read ID block error checking, I see the serial number OK when it reads back the ID block, but I get an “sn not found” error in my app.

What’s going on?

I’m also running into some trouble using 9.62 as well. However, I’m working with a BL2510 (R3000 core module). When I run the write ID block program (found in this thread), the output states that the new id block is written, but fails to read back, with a return code of -3. Any one have any tips?


This is the reply I received from Rabbit tech support:

"Hello Richard,
We have a newer version of the write_idblock program for DC9.62. See attached. Follow the comments at the top of the program.

Cheryl Busch
Technical Support Engineer - Rabbit Brand"

Attached file was



Mind shooting that zip file my way? I’d like to try it out. Thanks!

One of my co-workers ran the write ID block program in the thread I linked to – it worked fine with DC 8.02…so that’s an option for a worst case scenario.

Hi, dick-san.

Where is the link to “” ?


Hi, I’ll do that in 24hrs - away from my main PC till then.

Please keep in mind that there are different WriteIDblock samples for different versions of Dynamic C. To avoid any confusion, it might be best to contact Tech Support for the correct sample that you need at

I hope this helps

Please provide some tips to avoid this problem. I keep on having to rerun the Write_ID block too often.
In other words, what might be the causes of this problem and how to avoid it?