iDigi Can't Find ConnectPort X2


When I have my ConnectPort X2 connected to my network, I’m unable to discover the device in iDigi, and if I add the MAC address manually, and try to configure it, I get code 500: Device Not Connected. The device has a solid green LED for power and a steady blinking green LED for ASSOC. I’m using a Mac with an Airport base station, though everything is through ethernet and not Wifi. I’ve tried Chrome, Safari and Firefox. In Safari, it says I don’t have Java 1.6 when I click “refresh” in the Add Device window, but this does not happen with Chrome or Firefox.

When I log in to my router to see the DHCP clients, the ConnectPort X2’s MAC appears, along with its assigned IP address. I can ping that address and get a response, which leads me to believe that I am have a problem with Java in each of the browsers.

Can anyone give me any leads on what I can try next? I’m only guessing it’s a Java/Browser issue so I want to ask around here before go crazy with installing/uninstalling java.

Matt Richardson

More information:
I tried connecting on a Windows machine on a different network. The device pops up in the add device window of iDigi, I can add it, but then I get the message “Failed to configure device to connect to iDigi.” And then I can’t do anything with it.

I open the program Digi Device Discovery, the device pops up. I click “Open web interface” and I get the error “Error 101 (net::ERR_CONNECTION_RESET)” from my browser. If I click “Telnet to the command line” in Device Discovery, I get a login: prompt, but I don’t know the the login. Portscanning the device’s IP shows that only the telnet port is open.


I finally figured out how to log in, but when I try to run

set mgmtconnection svraddr1="" conntype=client

on the command line (as advised by the manual) I get the error:

bad option: svraddr1="

I’ve tried so many variations on this, but nothing seems to work.

Probably a bit late for you now, but set the protocol to “en://” instead of “http://”. I was able to get it working with the following:

set mgmtconn conntype=client svraddr1="en://"