ConnectPortX2e indicates 'disconnected' on iDigi while the WAN port has a solid green LED

I just received an X2e to evaluate and when I added the device to my iDigi account, the device is indicated as ‘disconnected’.
However the WAN LED is solid GREEN which according to the documentation indicates the device is connected to iDigi.

Any clue whats going on?

Can you get into the Web UI of the device? You press the white button on the front and then you can log in (discovering it with the device discovery tool) and check out the connection status. Also, I would compare what the device discovery tool reports as the MAC compared to what you’ve added as the MAC (and what may be on the label), do they match?

I ran the Discovery tool and the MAC address is the same as on the label.
The product doesn’t have a Web UI according to the handout in the box. I tried navigating to its IP address and the page is not available.
In the case of an X2, I normally telnet into the gateway & debug. There’s no telnet available on this X2e either.

The MAC address of the device is 00409D441644.
Can you check it out?

It should now show up in your account, the problem is was that these beta units point to by default. I re-directed to, and that should allow it to show up as connected now.

Additional info about the X2E’s defaults and capabilities can be found in this important post:,9669