Is it possible to configure WiFi module over the WiFi?

I have no physical access to the XBee S6B module. It is up and running connected to the WiFi router and I can ping it from another device. I need to fix configuration, in particular, baud rate on serial interface. How can I do it remotely over the WiFi connection?

Sure, just enter its IP address in your browser and you should be able to pull up its web interface. If that is not an option, you can always use the OTA API function and modify any of the radios commands you desire.

I have doubts that XBee S6B module has web-server. Anyway it doesn’t work. I tried to use XBee Application Service according to documentation (p.44) by sending a packet from the client using the UDP protocol on port 0xBEE (3054). I tried example from the manual, no answer. Tried to send FR to restart the module - no reaction. I’ve used Packet Sender and my own application. Tested with different modules. Any ideas?

What firmware version are you working with?

FW version is0x2026

Yes, that version does offer a Web interface. Providing both your PC and the XBee module are on the same subnet, you should be able to view the page.

If you are not able to, then you may need to use something like Fil;e Zilla or some of the other FPT clients to create a socket and issue some remote AT commands via API frames to the module to adjust the settings.

As I understand from documentation to access web-page it is necessary to use AP mode. Tried, with other default settings, no success. Anyway, in my case I need to work with module in STA mode.
I don’t understand how can I use FTP client to issue remote commands. I thing Packet Sender is a sufficient program for this purpose. But as I already said it doesn’t work also. For example, I tried to send bytes array 0x42 0x42 0x00 0x00 0x00 0x00 0x02 0x00 0x01 0x02 0x46 0x52 to send FR (Software Reset) command. Module supposed to loose connection for some time. Instead there is not reaction.

Check you are not being blocked access to port 0xbee by a firewall on your PC. I have no problem getting OTA commands to work to my S6Bs. See my OTA firmware upgrade command line utility in another thread. You should easily be able to modify this example to send additional commands.

1 Like

Yes, it works. The problem was in incorrect format of data sent to the port. In particularly, in Packet Sender I didn’t put spaces between bytes to send. With help of Wireshark I figured out that I am sending actually only one first byte. Obviously firewall should be configured to allow this communication.
Also I tried your tool for firmware upgrade. It works well. Good job. Thank you.

NP. Glad I was able to help. Good to have confirmation the FW tool works for others.