Known problems regarding DTR, DCD signals when using Realport with Connectport TS 16?

Specifically, the DTR signal stays active after the tty port is closed, and the DCD signal is never asserted when a modem connects (however DSR does follow the modem state regardless of the altpin setting). This has been verified usng a breakout box to manually monitor and simulate the modem signals.

This does not appear to be a cabling/altpin issue, we are familiar with this and have deployed Digi Portserver II and Portserver TS in conjunction with thousands of modems for many years using the same cabling (8-pin RJ45 with altpin on).

What’s curious is that if you issue the “altpin=on” command AFTER the port has been opened by an application, DCD works correctly. Once the application terminates and the port is closed this reverts back to DSR though, and DTR stays on no matter what.

Another interesting observation is that if you stop the Realport driver and simply connect/monitor via the Connectport command line, both the DTR and DCD
signals work correctly.

Realport: dgrp-1.9-36 on Linux CentOS 5 kernel 2.6.18-194.el5
(also occurs with dgrp-1.9-17 and dgrp-1.9-31)

ConnectPort TS 16:
BOOT 82001107 release_82001107_C
POST 82001476 release_82001476_C (V1.1.3)
Stored EOS 82001474 82001474_G (V2.19.0.1)
Running EOS 82001474 82001474_G (V2.19.0.1)

Configuration settings:

set profile port=1-16 profile=realport
set serial port=1-16 altpin=on

We have also tried variations of the following serial settings, with no change in behavior:

flowcontrol=none closewait=0 sigsonopen=none


This sounds like something that should be submitted as a bug report to Digi.

Update: I contacted Digi regarding this and was told that it is a known issue. A firmware fix is in the works, but no release date has been set at this point.

I already reported this problem 2 months ago. At the reverse DTR is never actived while using with dial in modem.
Last answer from digi support is there is no DTR problem with the ConnecPort LTS.
Somebody has already tried ConnectPort LTS ?