portserver TS16 + external modem + 8pin RJ45


I am unable to communicate with an external modem using a RealPort device /dev/ttyaa00 via a PortServer TS16.

The modem is working fine when I use a local serial port.
The realport daemon is running fine ( latest build )
The PortServer TS 16 is using the latest firmware and POST image

I configured port 1 as a realport device and enabled “altpin”.
Using instructions on page 26 of the Digi Cable Guide ( RJ-45 8 pin to Modem (ALTPIN option) ) , I wired a DB25M to RJ45F adapter like this

if I do a “statserial /dev/ttyaa00” I can see the RTS value toggle as I power on/off the modem, but I am unable to initialize the modem using minicom or cu

I’d hate to go buy expensive 76000129 cables ( btw are those 8 or 10 pin ? )

Does anyone have experience using 8pin RJ45 connectors


was able to successfully talk to a cisco console using /dev/ttyaa00 and a cable built according to the Digi Cabling guide.

So the port is good, and the RealPort daemon is working properly.

Just something to do with external modems… I ordered a 76000129 , we’ll see if the problem is the cable.

An 8 wire cable will work fine with the altpin setting applied. The 76000129 cables are 10 pin.

We recommend confirming your cabling is pinned as follows:


Are you able to issue ditty against the port and see the settings?

ditty-rp -a ttyaa00

Are you able to use dinc to connect to the port?

dinc 9600 /dev/ttyaa00

If this fails, please advise the make/model of your external modem.

The wiring matches that diagram. ( I’m using pin 1 on the DB25 for GND, SHELL == pin1 , right ? )

[root@lab01 ~]# ditty-rp -a ttyaa00

onstr \033[5i offstr \033[4i term ansi
maxcps 100 maxchar 50 bufsize 100 edelay 100
-forcedcd altpin -fastbaud (9600) -printer -rtstoggle
-rtspace -dtrpace -ctspace -dsrpace -dcdpace
startc = 0x11 stopc = 0x13
-aixon astartc = 0x0 astopc = 0x0
speed 9600 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^; erase = ^?; kill = ^U; eof = ^D; eol = ; eol2 = ; swtch = ;
start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 1;
-parenb -parodd cs8 hupcl -cstopb cread clocal -crtscts -cdtrdsr
ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl ixon ixoff -iuclc -ixany -imaxbel
-opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
-isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop -echoprt -echoctl -echoke

[root@lab01 ~]# dinc 9600 /dev/ttyaa00

------ DINC — port=/dev/ttyaa00 ------
Type ~? for help.

Modem is a US Robotics 5686


When connecting to the modem using dinc, did you issue AT commands?

For example:

dinc 9600 /dev/ttyaa00






US Robotics modems require that the DTE port speed be configured to match the serial port. Here are more details on configuring US Robotics modems:


when I connect with dinc, If type something, I get no echo or response. ( works fine when using local serial port )

I followed the instructions outlined in the knowledge base article, same result.

I also tested with a working Hayes ACCURA 56K , same result.

No modem response really points to cabing. Have you received the Digi modem cable yet?

What happens if you place the provided loopback plug into the port and use dinc to connect? Do you see data typed echoed on the dinc session?

If so, it would definitely point to a modem cable issue.

Not yet. Should be here tomorrow ( along with my 2nd TS16 )

Using the loopback plug and dinc, echo works fine.

Thanks, I checked and rechecked the adapter… I guess we’ll wait before the cable shows up.

The port works without the modems attached and passes loopback testing. 2 modems work on another serial port using another cable.

So, if the port works and the modems work, the only item left is the cable.

76000129 showed up, modems works great with it.

I wired the adapters properly, and I’m using altpin. I don’t know why they don’t work. The only thing I’m unsure about is the where GND goes on the DB25, one document says SHELL , another says pin 1.

oh well , I have other things to do than monkey with serial adapters, I’ll just order a pile of Digi 10 pin cables for my modems.

thanks for your help !

Either “shell” or pin 1 of a DB25 connector can be used for the chassis ground, and these would normally be connected to the braid of the serial cable so both diagrams are right. Connecting the shell and braid of the cable to Chassis Ground is useful in preventing noise interference with the serial lines.

Important: Never connect Signal Ground (DB25 pin 7) to a chassis/true ground, as this may create a ground fault issue which will end up burning out the port.