I tried it, but I'm still lost

Thanks for the reply userid. I created a cable according to the layout on your second link. It’s still not working for me, but I have many more questions…

1.) As a sanity check, when the 16-port Digi is connected to the PC, it adds 16 more COM ports on the computer. So I am printing to COM6 which corresponds to Digi port 4 where the printer is plugged into. Would that be correct?

2.) The Digi has a 10-pin loopback RJ50 plug plugged into a port on the digi which we don’t use and don’t have configured for any devices. Would that cause any problems?

3.)For the cabling guide you provided, it’s recommending that altpin be enabled. In my Digi’s web config, in the MEI settings for the port, the only way I can enable altpin (that I’m aware of) is to change it from EIA-232 to EIA-422/485 and checking the 4-wire option so I can finally check the ‘enable altpin’ option. Is this correct, or should I leave it on EIA-232? I ask because on our other two Digi portservers with printers, we don’t even have to config the ports for the printers and they work out of the box.

4.) In the digi config for this port, should the Port Profile be set to ‘Printer’, RealPort, or completely undefined?

-I am using pin 20 for DTR and then setting the printer to use “DRT- Pin 20” via it’s physical configuration switches.
-On the printer its DSR Input Signal is set to Active (other possible option is Inactive which I also tried.).
-Basically I am using the defaults on the printer as detailed on Page 37 here, except for switch 7 and 8 to ON, ON to use DTR over SSD.

  1. Yes, this looks correct.

  2. This would not cause any problems.

  3. You definitely want this set to RS232. You can find the altpin setting in the web interface under Serial Ports > (select port number) > Advanced Serial Settings > Enable DCD on 8-pin RJ45 connectors (Altpin).

  4. The profile should be set to RealPort since you are using a COM port.

Other Comments: You should set the DSR input Signal to inactive/invalid when using the altpin setting. Also, make sure the COM port is configured to use hardware flow control.

Hi userid0, thanks again for the info. I can’t believe I was missing where that altpin toggle switch was. However, Still no luck when using this cable with altpin turned on (or off): http://ftp1.digi.com/support/cabling/term_print_rj45_8pin_altpin_db25m.pdf

Here is what I have tried (all with Alt pin on, RealPort, and the PC set to Hardware flowcontrol):

-When pin 11 is wired for SSD I’ve tried it with the printer set to SSD- and SSD+, and tried each of those in conjunction with setting the DSR Input Signal on the printer to both on and off. No luck.

-I then unwired Pin 11 and wired pin 20 for DTR. I adjusted the printer to use DTR- and tried with with DSR signal set to on and off. Still no luck

-Out of desperation, I tried reversing the wiring of the Tx and Rx pins and re-walked through the above things I tried with Tx/Rx flip-flopped, still no dice.

-I tried connecting the Digi to another computer, installed its drivers, and tried things through a second computer just to be safe. No luck.

-Confirmed that on the PC side the COM port is set for hardware flow control (both in the printer and in Device Manager).

At this point I’m afraid that the pinouts on that cable is too much for me to figure out and troubleshoot. That leads be back to the much simpler DB9 to DB25 serial connection which I CAN make work using Hardware flow control, DSR Input Signal = Active, and SSD- instead of DTR.:

DB9 PC <–> DB25 Printer
2 (Rx) <–> 2 (Tx)
3 (Tx) <–> 3 (Rx)
5 (SG) <–> 7 (SG)
6 (DRS)<–> 6 & 20 (DSR & DTR)
8 (CTS)<–> 11 (SSD)

Is it possible to port the above pintout from DB9 to 8-pin RJ45 to use in a Digi? On the Digi end of this, I’ve tried putting SSD to pin 7, printer DSR&DTR to pin 1 (with altpin off), ground to pin 6, and printer’s Tx to pin 5/printers Rx to Pin 4. That does not work even though to me it’s just porting the points to a RJ45 format for the digi.

What am I missing to convert my above pinout to work on a Digi Portserver?

If using the Supervisory signal (SSD), the following pin-outs will apply:

RJ-45 Signal Signal To DB-25
============ ==============
5 RxD TxD 2
4 TxD RxD 3
8 DTR DSR 6 and DCD 8
6 SG SG 7
7 CTS SSD 11
3 GND GND Shell

You would enable hardware flow control on the Digi port.

if configuring the Okidata for regular hardware flow control, wire pin 20 (DTR) from the printer to pin 7 on the Digi.

If this does not work, you might want to try setting it to use software flow control, just to confirm the printer is working.

More information on Okidata printer configuration can be found here: http://knowledge.digi.com/articles/Knowledge_Base_Article/Okidata-Printer-Configuration-Tips

Thank you userid! That worked! Thanks for sticking with me one this. I know for a fact I’ve tried that pin configuration before, but with a fresh start it worked using the default dip switch positions for SSD- flow control on the Oki with Hardware flowcontrol on the PC end, through real port, with alt pin turned on. I have a feeling that it didn’t work in previous times was due to me not fully powering down and equipment and powering it all on again when making changes.

Thank you again!

Great news, glad I could help!