Line passing in command mode


I am using two XBee modules trying to get line passing to work.

On my local module I have one input that is ‘line passed’ to an output on a remote module. That works!

Now I connect the input on my local module to an output on the same module.

I change the local output in AT command mode.
If sample rate (IR) is set the output on the remote changes after leaving command mode because the IO data is sent cyclic.
If I use change detect (IC) and set IR=0 then nothing happens on the remote output.

I think that when in command mode the change detect does not work and no IO update message is transmitted to a remote module.

Is there a possibility to force IO data to be sent once when in command mode?

I don’t want to use automatic sampling (IR>0) because it interferes with the communication in transparent mode!


I found a workaround for my problem.
Not nice but works…

Control an output on a remote XBee device form local XBee device.


  • Turn on ‘Line passing’ for the output on the remote module (IA)
  • Connect output with input on local module
  • Set output on local module in command mode by command (D)
  • Turn on sample rate (IR=10)
  • Exit command mode
    (Now the IOs from the local module are updated on the remote module)
  • Enter command mode
  • Turn off sample rate (IR=0)
  • Exit command mode

The reason for this strange procedure is that the air traffic from line passing interferes with the normal communication in transparent mode!

Line passing could also work with change detect (IC) but changes on the IOs are not recognized when command mode is active!

It would be nice to have a command to update the remote IOs (line passing) in command mode!