Link Testing in API mode problem

I have problem with link testing in API mode with ZigBee Meshnetwork.
I have make the link testing with X-CTU work by setting the CI to 12, SE and DE to E8. The remote module will echo back the data.
While I do the same thing with API firmware using explicit addressing command, it showed the data package has been sent correctly by return transmit status package, but there is no data echo back from remote module. In stead of the echo back, it seems that remote module received the data as I use cluster id 0x11.
I followed the instruction of page 74 on doc 90000976_C.pdf.
Here are firmware set.
Coordinate 2164
End Device 2964

I also tried 2064, 2864, 2264, 2364, none of combination works. The mesh network is setup correctly, as I can send receive in both broadcast or specific addressing way.

I also tried ZigBee Operator, which is a tool like X-CTU, but support API mode and can send explicit addressing command directly. The result are same.

I am wondering if any one has luck of link testing in API mode?