XCTU XBee ZB API Mode and Range Test Problem

I’m brand new to the XBee Pro ZB but I am having great success with it so far. There’s one puzzle I haven’t been able to solve. With the coordinator in API mode and X-CTU connected to the coordinator, and an end node configured to loop back data to the coordinator, I can’t get the range test to work. It just reports timeouts waiting or data. Everything is default, the nodes are configured exactly like the X-CTU manual states for the API range test.

In transpararent mode the range test works fine. So I know the remote node is looping back properly. I know the API mode is working because I can configure nodes over the air and update software over the air. I further know the API is working to the remote node because I can manually form and transmit a AT ND API command via the terminal and I get good node discovery data back. And I can also manually form and transmit a transmit request (type 0x10) and I get both a positive transmit status (type 0x8B) and also a returned receive packet (type 0x90). So I believe the modules are working perfectly. But range test still doesn’t work.

X-CTU Version
ZB Hardware Version 1A44
ZB Firmware on coordinator 2164
ZB Firmware on end node 2864

I’m stumped. Any thoughts?


My results are still the same, everything seems to work except the range test. Does anyone use CTU range test in API mode? And does it work ok?

The API option in the range test was developed about 4 years ago for the 9XTend. Since then we have standardized on the API interface and released several new products. Unfortunately, the API option in the X-CTU’s range test has not been updated. As such, you are unable to use the range test option with an XBee node in API mode.

OK. Thank you for the reply.