XCTU range test unexpectedly stopped working (xbee pro s1)


I’ve been using two arduino uno usb boards and several xbee modules for about a month, making different tests, including loopback range tests. Everything was working good. But today unexpectedly I started to see this picture:
Local dBm - unknown (“?” sign)
Remote dBm - is showed normally
Packets lost - 100%

I installed XCTU to other new PCs, used other xbee modules, two different arduino boards, but all the same - range test acts as showed.

I even do not know what to think, that’s just a miracle :slight_smile:

Any ideas?

Try using API mode on your local node (PC Side).

I wish it would be so easy :slight_smile: Actually it’s impossible to make range tests when both modules in a transparent mode. Of course local module just should be API enabled.

No it’s not. Simply either connect DI to DO on the remote side or set the TO command on your base module to use the loop back cluster ID.

Ok, perhaps there is such way to do it, but it’s completely another subject and unfortunately it doesn’t help to fix the situation. :frowning:

Oh yea, 802.15.4 does not have the ZDO commands support. Try restoring both to defaults using the ATRE, WR commands. Then run the range test as normal shorting out the DI and DO lines on the remote.

Just understand that the RSSI function for this product only works in one direction with transparent mode. In order to see it for both sides, API mode on the local side would be required.

Actually I did better - I took new, just unpacked modules and tried to make tests (as well ac PCs). The same. The only modules I can’t replace are Arduino USB adapters - I’ve got two only. Logically it’s something wrong with this adapters. Is it possible to make something like restoring to defaults with them?

What product are you referring to that you want to restore to defaults?

The Arduino USB Adapter or the XBee modules?

Arduino USB Adapter.

The only software that exits for that is the USB driver. Short of removing the driver and reloading it, I don’t know of any other way. You may simply need to replace the hardware as it may not be a software related issue.

I bought two new xbee arduino usb boards. The same situation.

And I found that although a throughput test works, it works in unidirectional mode only. In loopback mode it doesn’t as well as a range test.

What modules, firmware version and settings are you using for both radios?

Win7 Pro, Arduino driver (http://www.dfrobot.com/image/data/DFR0174/atmega8u2%20usb%20driver(Windows).zip)
XBee usb adapter v2.0 (http://www.dfrobot.com/index.php?route=product/product&product_id=588&search=xbee&description=true#.Vw-c9jB97IU)
XBee Pro S1 (API enabled) (http://www.dfrobot.com/index.php?route=product/product&product_id=145&search=xbee&description=true#.Vw-dojB94dU)

XBee Pro S1 (API disabled)

It’s works as expected on the ones I have. Both local and remote RSSI report using one is API mode (Base) and the remote in transparent with a loop back jumper connected.

What version of XCTU are you working with? The version I am working with is 6.3.0 build 20151110-8.

I work with the same version.
Before “Day X” my devices worked just fine, that’s a problem.
And, by the way, without a loop back jumper.

If you don’t short Data In to Data out, I have no idea how you are going to get a range test to work on the 802.15.4 XBee modules using the 802.15.4 code.

The range test functions by sending a 32 byte packet to a given address and expects it to come back within a given time frame. If you do not short Data in to data out on the remote side, the data will just be sent out into the air and noting will be sent back.