Unable to communicate with modem; XBee PRO XSC, X-CTU v

Unable to range test; “Timeout waiting for data”

Test/Query button on PC Settings screen results in:

With Enable API Unchecked:

 Unable to communicate with modem

WITH Enable API Checked and EITHER (ATP = 2) checked or unchecked:

 Communication with modem..OK
 Modem type = unknown (ID = 4294967248460014)
 Modem firmware version = 

LEDs on USB Board (XBIB-U-DEV REV. 3): Right bank: all 3 leds green; left bank, All 3 leds off, except when attempting to run range test, middle left led blinks with data packet.

LEDs of Serial Dev Board (XBIB-R-DEV REV. 4): Right bank (right of serial connector)L all three on, green. Left of serial connector, bottom (red) led on, top two off. LED3 (small surface mount LED on board) is on, yellow. All others off.

Null Modem connected with loopback plug.

Unable to get any evidence of communication between the two units.

Lastly, PC is running Windows XP sp3. Digi PKG-U Serial Port Adapter shows configured on COM6.


Thank you very much!


Withing X-CTU go to the terminal tab. Send +++ and the module should respond with OK. If it does not then try to wiggle the module in the development board and try it again. Also, you do not need to use the null modem adapter with the loop back adapter.

+++ doesn’t work - I never even get the OK back. The null modem w/loopback was just the setup for the RX side as instructed in the initial setup guide in anticipation of doing a range test, but yes, since I cannot even establish comm with the local unit, the second setup is entirely unnecessary as of now… Calling Digi Techs now…



I have the same problem, the XBee card seem to be in a strange mode, I tried all the tutorial I found but it seems that I received a broken card, not very happy.

What you can try, set the baudrate to 38400 (Flow none, 8-none-1) in X-CTU (PC Settings), then go to Terminal and type some letters, especially the letter V (capital). If the card responds (written in red), then we really have the same problem, the XBee card is in a strange mode which seem to be a huge bug and I havent solved it now :frowning:

It turned out to be the USB XBIB-U Dev board I had. I’m returning it to Digi, and I ordered a second serial board instead. I even tried it on a second computer with identical results. The second serial board arrived already, and I am happy to report the XBees are now embedded in their live application pc board and happily talking with each other. Also… You mention baud settings, and for the XBee PRO XSC, the MAX baud rate is 9600. If you are running your XBees from a microcontroller (or anything for that matter) be sure to triple check your baud rate settings on both ends.

Good luck!

Dave X

Did anyone ever figure out what this is? I have two Xbee 802.15.4 devices that seem to be dead like that, they seem to have set themselves to 38400 bps and respond with “U” to anything you type except “V” to which they give some gibberish. I assume this is some kind of bootloader that it’s falling into due to a firmware bug?

At any rate, I am not exactly sure how I “killed” these two modems, but neither of them died while in an XBIB-U dev board, at any rate. They both failed while I was experimenting with sleep modes - they were talking to a “coordinator” node while in cyclic sleep mode and were connected to a microcontroller which went into its own sleep mode. Maybe they freak out if they get UART framing errors while sleeping? I’m hesitant to try any more experiments at a cost of $22 per failed test.

Anyway, just to let you know it doesn’t appear to be restricted to either XSC modules or XBIB-U boards.


I ran into the same problem today.
Two XBee2s are dead and I am pretty sure, how I managed this:

During setting up I worked with the minimum wiring between the Bee and the MAX232 (Vcc, Gnd, Rx, Tx). X-CTU did not read the settings of the Bee and after some other tests I changed the PAN-ID only and hit the “Write” button.
I guess that all other parameters were set to zero or any other default. Therefore the baudrate maybe is 1200 and the escape character 0x00. But that might be not all. Could be that I sent them into permanent sleep as well. Since then there is still no response.

I installed the extra wires for RTS and CTS and hoped, that I could do a firmware update but X-CTU still can’t manage it.

Maybe some other wiring is necessary to reinitialize it, but Google didn’t show any further information.

Did anyone ever ask DIGI about this and does it make sense to spend more time for investigations?

Greetings, Manitux