Loading RealPort Driver in a Solaris 10 zone

Is there any validated information for loading the RealPort driver to function in a Solaris 10 local zone? Our team has used PortServer TS 8/16 units, successfully with Solaris 8, with experience loading and setting up the driver.
We are trying to migrate to Solaris 10 and can only get the driver to load in the global zone. The install for the local zone is attempted but fails with the following errors listed below.
We suspect a pathing issue, but the zone is a whole root zone with what appears to be all the appropriate paths/permissions. Any help would be appreciated.
We’ve tried drivers: 2.7.8 and 2.8.3

[verifying class ]
Error: attribute verifcation of failed pathname
does not exist unable to create directory
"same error for "

Executing postinstall script using / as package base directory

grep: cant open /etc/name_to_major
/var/sadm/pkg/realport/install/postinstall: /kernel/drv/digi_realport.conf: cannot create pkginstall.Error: postinstall script did not complete successfully.

Hi Harris,

The RealPort driver should be installed into the Global Zone, and then the ttys given out to each local zone’s /dev path as needed.

The driver should NOT be installed in a local zone, and very likely would fail like you are seeing.


Thanks Scottk,

I have a little more information as we continue effort:

When we load the driver version 2.8.3, it will automatically attempt to boot the zone into a administrative mode even when we are only attempting to load the software into the global zone. We can ignore the errors, but we still haven’t been able to configure a zone (with zonecfg command) where it will show any tty ports in the local zone. We can, however, see the ports in the global zone.
We’ve tried doing a zonecfg “set device” and entering “match=/dev” --but with no luck. We’re plowing through the sun documentation.
Anyone know of a zonecfg format that might work?

Thanks in advance

I am having the same problem.

Has anyone found a solution?



I believe the solution might be found in the latest Solaris Realport driver, version 2.8.5.

Reason I say this is because of a bug fix listed in the release notes for the 2.8.5 driver:

Fixed problem with unneeded ZONES commands in the pkginfo file.

Please give that a try and let us know.

Hi all, Michaelt,

The new driver will NOT help in this case.
The failure addressed in the new driver is a case where during package install, the pkgadd command would refuse to install the driver because of a ZONE command in the pkginfo file. This ZONE command has been removed.

The problem in this question is 2 fold.

  1. You cannot install the RealPort driver into a subzone. It MUST be installed into the global zone.
  2. After this install, the zoneadm doesn’t appear to see the RealPort devices. This is the real problem.
    During my investigation, it appears that zoneadm doesn’t correctly read /dev to allow said devices to be configured into the subzones. Its unclear why. You CAN manually mknod any of the RealPort devices into the each subzone zone, and that works just fine. But why is it that zonecfg/zoneadm doesn’t allow the config of the devices is a mystery to me. Whether its a bug in zonecfg/zoneadm, or whether its intentional and SUN only wants its “native” serial ports to be configured for ZONEs, its hard to say…

Thanks for the heads up Scott. I thought the two issues were related but apparently not.