Multiple XBee3 Cat-M/NB-IoT bricked after 11417 failed update

Good morning,

I am starting to accumulate bricked XBee3 LTE-M units. The issue seems to occur when I attempt to update devices to 11417 from 11415 firmware. I don’t recall ever having success updating to 11417 firmware. I tried updating incrementally as well too; updated from 11415 to 11416, then to 11417.

I tried multiple things to try to recover the units, but I am not having any luck (full formats, the recover tool, manually deleting files from python, etc. I keep getting errors that describe the unit not having compatible memory. This leads me to believe somewhere during the update, the memory is being corrupted. I have just stopped updating devices that currently have 11415 firmware. Anyone have any ideas how I can recover them? Anyone else encountered this?

Thanks for any input


From your description it sounds to me like you’re getting an “incompatible .mpy file” error in MicroPython. This is not an indicator of any corruption or bricking. Please see the product release notes - in the 11416 release we updated to MicroPython version 1.12, which uses a new bytecode version and therefore requires you to byte-compile your code again.

I am used to seeing those types errors.

I can’t even move files to the device itself, nor can I delete or download any files either. I tried flashing via paste mode and also through PyCharm without any luck. I have tried using the file system tool in XCTU and also attempted to access files via python command and I had no luck. I’ve been at our shop the past few days, but I have a box of bricked units that I can fire up and take some screen shots/vids.

Ultimately, I’d just like to be able to recover them and make them usable.

So just to confirm - you are able to format the XBee’s filesystem (ATFS FORMAT CONFIRM), after which you can see the filesystem (ATFS INFO ; ATFS LS /flash), but you are either unable to write files, or unable to import files?