XBee LTE-M Failing cell modem update

I’m updating the cellular modem firmware on my XBee LTE-M/NB-IoT device. It is failing at the end of the update (98% point) with:

Error occured!
[Boot Failed]

  • Transferring cellular modem firmware…(retry #2)…(retry #3) …etc…

I’m using the Digi XBIB-CU-TH development board to perform update.
I’m using X-CTU ver: 6.5.1
XBee firmware ver: 11415

I end up having to shut down X-CTU for it to stop. When the XBee comes back up after X-CTU restart it will pull the configuration data with the exception of the cellular modem information.

1 Like

Try rebooting and run the update again.

I’ve had this problem as well.
I have the USB C connected to the front of a brand new Xbee TH,
a microUSB connected to the “USB Direct Connect” through a USB Hub.

The first time, after updating to 11415 (from 11413) the “updating radio firmware” pop up “Details” text box said

  • Waiting for module to reset… [OK]
  • Transferring cellular modem firmware…
    It got up to "Programming cellular modem : 98 % and failed with the following

u-blox AG EasyFlash CLI downloader v.10.02
Processing ‘fw_L0.,A.02.04.dof’
Please TURN ON the device and don’t disconnect power supply
Waiting for device…
Device found!
Mobile Version report: PASS
Ext Mobile Mobile SW Rev: L0.
-> Backup of legacy NV objects
Process time was 14.4 sec.
-> Backup of ublox legacy NV objects
Process time was 31 msec.
-> Backup of RF NV objects
Process time was 4.5 sec.
-> Backup of CONF NV objects
Process time was 3.1 sec.
-> Switching to emergency download mode
Waiting for synchronization…
Error occured!
[Boot failed!]

  • Transferring cellular modem firmware… (retry #2)
    (retry #3)…

I tried a 2nd time powering off the XBEE/XB-TH board, waiting 10seconds, then powering and trying again.
Same result