XBee 3 LTE-M cell firmware update fails


I have the XB3-C-A2-UT-001 cell module, and I can’t get the cell firmware update to complete in X-CTU. I am using the XBIB-CU-TH dev board and set to cell bypass mode, and it always gets stuck in the state “Waiting for modem port…” for a very long time (about 5 minutes per try), and after retrying 3 times it quits with error “Could not communicate with the cellular modem over USB”. I tried reinstalling the cellular drivers from ublox and that did not help. I even tried another Xbee module and still had the same issue. I am wondering what else to try to get it to work.

Are you connecting the Micro USB cable to the board and PC as well or just the main USB cable?

1 Like

I have both cables plugged in

Check the two switches by the Micro USB port and make sure they are set to facing the edge of the board.

Yes they have always been set to the edge of the board and it still does not work

What I would suggest is contacting Digi Support at tech.support@digi.com

Try these steps:

  • Slide switches left towards board end or I2C bus is disconnected in custom hardware.

  • Ensure both USB’s are connected to computer and device manager recognizes the XBee FTDI chip.

  • Ensure the USB C is connected to a USB 3.0 port on your computer for XBIB-CU-TH or the XBee is sufficiently powered in custom hardware. Powering specs in manual.

  • Configure the modem in XCTU:
    ~ First write default settings.
    ~ Write ‘Bypass Mode’ to AP
    ~ Write ‘USB Direct’ to P1 (Configs GPIO for modem USB)
    ~ Write ‘4’ to DO (Enables USB modem VBUS)

  • Press the reset button.

  • Ensure your computer now recognizes the Qualcomm modem in device manager.

Proceed as usual.

1 Like

It turns out that the 2nd USB cable was somehow bad- I tried with a different cable and it worked.

Thank you soterboat. Digi does not have this procedure anywhere to be found. How did you find this procedure? It actually worked for me. Shame on Digi for lack of support.